Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎11-12-2018

Error "Failing Oozie Launcher,Main Class [org.apache.oozie.action.hadoop.Hive2Main], exit code [2]"

[ Edited ]

We had a cluster with version 5.5 of kerberos (8 nodes). On the cluster, tasks in oozie were successfully running. We updated the cluster to version 5.13. After that, an error began to appear. And the task can then run back, then after, for example, 8 times not to run back. Error: Main class [org.apache.oozie.action.hadoop.Hive2Main] exit code [2].
error.jpg
There are no details in the oozie and sheduler logs.

When testing errors it was revealed:
- Occurs when the hive2action block is executed.
- At numerous attempts, it was revealed that out of 10 attempts approximately 1 time the script runs off. In this case, the input data, connection logs of libraries, etc. were compared and were identical.
- Oozie script is written correctly, all dependencies are used.
During testing, 3 run statuses were identified (two that fell with errors and one ran away): no connection1-2.jpg, interrupted connection1-2.jpg, success connection1-2.jpg.

1. success connection - the script ran away. In the second screenshot, you can see that the connection went to beeline and !сonnect... with the appropriate parameters, and then the insert ran off, which is shown in the logs on screenshot 1.
success connection.jpgsuccess connection2.jpg

2. no connection - the script fell. On the 2nd screenshot you can see that there is an attempt to connect to the beeline, as if !сonnect... parameters were not applied. BUT, these parameters (url, principal) were passed and this can be seen in the oozie coordinator of the web-face of this oozie action.
no connection.jpgno connection2.jpg

3. interrupted connection - the script fell. In the 2nd screenshot, you can see that the parameters were connected to the beeline with the appropriate! Connect parameters, but then it seemed as if there was a break. And from the 1st screenshot you can see that the error “Failing Oozie Launcher, Main Class [org.apache.oozie.action.hadoop.Hive2Main], exit code [2]” also went

interrupted connection.jpginterrupted connection2.jpg

Please help!

Cloudera Employee
Posts: 53
Registered: ‎04-03-2017

Re: Error "Failing Oozie Launcher,Main Class [org.apache.oozie.action.hadoop.Hive2Main], exit c

Hi,

 

Kindly check if there are some conflicting jars in the stdout logs where you are not able to connect to Hive.

 

As this is an intermittent failure, I am afraid this could be the cause.

 

Regards

Nitish

Cloudera Employee
Posts: 53
Registered: ‎04-03-2017

Re: Error "Failing Oozie Launcher,Main Class [org.apache.oozie.action.hadoop.Hive2Main], exit c

Hi,

 

Just to be accurate, Kindly check for these 2 jars as per your CDH version and see if there are multiple versions of jar for these 2.

 

##  hive-jdbc-1.1.0-cdh5.12.2-standalone.jar matches

## hive-service-1.1.0-cdh5.12.2.jar matches

 

Regards

Nitish

Announcements