Reply
Highlighted
Expert Contributor
Posts: 68
Registered: ‎10-04-2016
Accepted Solution

Cloudera Director should support password validation in MySQL 5.7.x or disable it with admin user

MySQL 5.7 is listed as supported DB version. However, Cloudera Director generates passwords not suitable for 5.7 standard. Application log is shown as follows:

[2017-01-24 22:46:13] INFO [io-thread-38] - ssh:10.3.1.154: [ main] DbProvisioner ERROR Stack Trace:
[2017-01-24 22:46:13] INFO [io-thread-38] - ssh:10.3.1.154: java.sql.SQLException: Your password does not satisfy the current policy requirements
[2017-01-24 22:46:13] INFO [io-thread-38] - ssh:10.3.1.154: at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1078)[mysql-connec
tor-java.jar:]

 

 

Cloudera Employee
Posts: 40
Registered: ‎02-18-2014

Re: Cloudera Director should support password validation in MySQL 5.7.x or disable it with admin use

Hello zhuw.bigdata,

 

This is a known issue with Director's automated generation of passwords for MySQL databases. There is a fix for it included with Director 2.3, which is due to be released soon. In the meantime, you can try adjusting the password validation level in MySQL 5.7 to LOW, instead of the default MEDIUM, and Director's passwords should be accepted.

 

Director uses ordinary random UUIDs as passwords, and they fail the MEDIUM level of MySQL password validation because they lack an uppercase letter (and may, in very rare cases, lack either a lowercase letter or a number).

Expert Contributor
Posts: 68
Registered: ‎10-04-2016

Re: Cloudera Director should support password validation in MySQL 5.7.x or disable it with admin use

Thanks. As a workaround, I just disable password validation via ansible script right after mysql initial installation.
New Contributor
Posts: 5
Registered: ‎06-03-2016

Re: Cloudera Director should support password validation in MySQL 5.7.x or disable it with admin use

# cp /etc/my.cnf /etc/my.cnf.default
# vim /etc/my.cnf
--------------------------------
[mysqld]
# Disable password validaion plugin
validate-password=off
--------------------------------
# systemctl restart mysqld

Announcements