Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Connection to Metastore fails with "MetaStoreClient lost connection" error

avatar

Metadata fetch for Impala on CDP fails with below error:

INFO: Connected to metastore.
alation.shims.HiveShimsBase$RetryingMetaStoreClient invoke
WARNING: MetaStoreClient lost connection. Attempting to reconnect (3 of 3) after 1s for getTableObjectsByName method with arguments: [test_sampling_and_profiling02, [stpsalewithmt1000drows, stpsalewithmt1000drows_view, stpsale_view, stpsalesample_view]]
org.apache.thrift.TApplicationException: Internal error processing get_table_objects_by_name
	at org.apache.thrift.TApplicationException.read(TApplicationException.java:111)
	at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:79)
	at org.apache.hadoop.hive.metastore.api.ThriftHiveMetastore$Client.recv_get_table_objects_by_name(ThriftHiveMetastore.java:1496)
	at org.apache.hadoop.hive.metastore.api.ThriftHiveMetastore$Client.get_table_objects_by_name(ThriftHiveMetastore.java:1482)
	at org.apache.hadoop.hive.metastore.HiveMetaStoreClient.getTableObjectsByName(HiveMetaStoreClient.java:1431)
	at jdk.internal.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.base/java.lang.reflect.Method.invoke(Method.java:566)

CDP: 7.1.7

1 REPLY 1

avatar
Master Collaborator

Hi,

> Add the below configuration in HDFS from CM UI: CM -> hdfs -> Configuration 

 

hadoop.proxyuser.hive.hosts = *

hadoop.proxyuser.hive.groups = * 

 

> If the above is already set, please disable the DB notification API auth. 

In Hive and Hive_On_Tez Service:

In Hive Service Advanced Configuration hive-site safety value: 

 

Name: hive.metastore.event.db.notification.api.auth

Value: false

 

Restart stale configs and check if it works.

 

Regards,

Chethan YM