Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-31-2023 06:30 AM
We are upgrading our cluster from HDP 2.6.5 to HDP-7.1.70 :
During the upgrading process ( about 65 %), it fails to restart the mapreduce/historyserver with the below error.
Unable to find a solution
Any idea or help ?
raceback (most recent call last):
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/YARN/package/scripts/historyserver.py", line 126, in <module>
HistoryServer().execute()
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 352, in execute
method(env)
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 987, in restart
self.stop(env, upgrade_type=upgrade_type)
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/YARN/package/scripts/historyserver.py", line 47, in stop
import params
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/YARN/package/scripts/params.py", line 29, in <module>
from params_linux import *
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/YARN/package/scripts/params_linux.py", line 374, in <module>
yarn_registry_dns_principal_name = yarn_registry_dns_principal_name.replace('_HOST', hostname.lower())
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/config_dictionary.py", line 73, in __getattr__
raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'yarn.registry-dns.principal' was not found in configurations dictionary!
Created 04-02-2023 10:24 PM
so it looks like Ambari is looking for an Configuration : yarn.registry-dns.principal and its missing in Configuration.
Can you see adding to yarn-env in Yarn Services configuration helps ?
For ex , you can add it via commandline from Ambari serve r:
/var/lib/ambari-server/resources/scripts/configs.py -l <AMBARI_HOSTNAME> -t 8080 -u <USER_NAME> -p <PASSWORD> -a set -n <CLUSTER_NAME> -c yarn-env -k 'yarn.registry-dns.principal' -v 'yarn/[email protected]'
In the abouve example i am adding yarn/[email protected] as value of config : yarn.registry-dns.principal , see if this helps.
Created 04-02-2023 10:24 PM
so it looks like Ambari is looking for an Configuration : yarn.registry-dns.principal and its missing in Configuration.
Can you see adding to yarn-env in Yarn Services configuration helps ?
For ex , you can add it via commandline from Ambari serve r:
/var/lib/ambari-server/resources/scripts/configs.py -l <AMBARI_HOSTNAME> -t 8080 -u <USER_NAME> -p <PASSWORD> -a set -n <CLUSTER_NAME> -c yarn-env -k 'yarn.registry-dns.principal' -v 'yarn/[email protected]'
In the abouve example i am adding yarn/[email protected] as value of config : yarn.registry-dns.principal , see if this helps.
Created 04-03-2023 12:56 AM
It solved the problem
Thanks