Support Questions

Find answers, ask questions, and share your expertise

ExecuteScript error - ECMAScript is missing

Explorer

Hi,

 

moved Ni-Fi 1.16.3 folder from one destination to another and now getting error for ExecuteScript processor:

 

'Script Engine' validated against 'ECMAScript' is invalid because Given value not found in allowed set 'Clojure, Groovy, Lua, Python, ruby'.

 

Any idea what's wrong?

 

Thanks a lot. Ludvik

1 ACCEPTED SOLUTION

Explorer

ok, I found this https://en.wikipedia.org/wiki/Nashorn_(JavaScript_engine)

With the release of Java 11, Nashorn was deprecated citing challenges to maintenance, and has been removed from JDK 15 onwards.

View solution in original post

2 REPLIES 2

Explorer

ok, I found this https://en.wikipedia.org/wiki/Nashorn_(JavaScript_engine)

With the release of Java 11, Nashorn was deprecated citing challenges to maintenance, and has been removed from JDK 15 onwards.

Master Collaborator

@Luwi , please note that NiFi currently only supports Java 8 and 11.

 

Cheers

Andre

 

 

 

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.