Support Questions

Find answers, ask questions, and share your expertise

Failed to connect node to cluster because local flow is different than cluster flow.

Contributor

Hi,

We are currently using HDP 3.0 with ambari and we installed 2 nifi nodes.

 

We made some config changes on nifi node01 without restarting both nodes (i only restarted the node01 and not node02). The changes were not working properly so we decided to roll back to the previous configs but whenever i try to start node01 i am getting the following error:

Failed to connect node to cluster because local flow is different than cluster flow.

 

My guess would be that both nodes are out of synch.... How can we fix this issue?

 

Thank you for your help.

2 ACCEPTED SOLUTIONS

Contributor

Hi @Shelton 

when you said authorizations.xml are you talking about authorizers.xml? the hadoop environment use ranger for the securioty and also is connected to a ldap server for the users and groups. I don't see any users.xml in the conf directory.

 

 

View solution in original post

Rising Star

Hi @Koffi 

Not sure if you have ambari metrics enabled?

 

If you dont then I would just simply delete the flow.xml.gz typically found under: on <node01>

 

/usr/hdf/current/nifi/conf

 

Assuming you have HDF managed by HDP ambari.

And then restart your nifi

 

If you do have amabri metrics enabled then do the same thing but instead restart the nifi from the command line on node01

$NIFI_HOME/bin/nifi.sh restart <Assuming you set a runas user on your bootstrap.conf> 

or run same command as user who will run nifi.

 

The reason ambari metrics plays a role here is that if you restart nifi from ambari AND you have ambari metrics enabled then once you remove the flow.xml.gz, ambari will see its missing and create a vanilla one with ambari metrics and will get a flow mismatch again.

 

Hope that helps!

 

Juan C.

View solution in original post

3 REPLIES 3

Mentor

@Koffi 

Indeed your HDF nodes are out of sync can you backup the users.xml and authorizations.xml node01 ie $ mv users.xml users.xml.bak and on the same $ mv authorizations.xml authorizations.xml.bak then if possible stop node02 so that there are no changes made when you attempt to copy these same 2 files over to node01, ensure the location  is the same and the file's permissions thereafter restart your 2 node HDF cluster.

 

That should resolve the issue.

Contributor

Hi @Shelton 

when you said authorizations.xml are you talking about authorizers.xml? the hadoop environment use ranger for the securioty and also is connected to a ldap server for the users and groups. I don't see any users.xml in the conf directory.

 

 

Rising Star

Hi @Koffi 

Not sure if you have ambari metrics enabled?

 

If you dont then I would just simply delete the flow.xml.gz typically found under: on <node01>

 

/usr/hdf/current/nifi/conf

 

Assuming you have HDF managed by HDP ambari.

And then restart your nifi

 

If you do have amabri metrics enabled then do the same thing but instead restart the nifi from the command line on node01

$NIFI_HOME/bin/nifi.sh restart <Assuming you set a runas user on your bootstrap.conf> 

or run same command as user who will run nifi.

 

The reason ambari metrics plays a role here is that if you restart nifi from ambari AND you have ambari metrics enabled then once you remove the flow.xml.gz, ambari will see its missing and create a vanilla one with ambari metrics and will get a flow mismatch again.

 

Hope that helps!

 

Juan C.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.