Hi, all, I have faced a problem when I use the hdp 3.1.5 with ambari , because the default hive version 3.1.0 is too high to use the spark 3.1(it's supported with hive version 2.3.7 ), so I need to downgrade the hive version to 2.3.7, how can I do it?
@Shifu Okay, got it, but we want to use spark 3.1, it recommend the hive metastore version is 2.3.7, `https://spark.apache.org/docs/latest/sql-data-sources-hive-tables.html`, how can I do for it? maybe downgrade the hive version is the only way.
@Bryan_zh I believe HDP 3.1.5 supports Spark 2.X only. Please check the below link
How to integrate Hive and Spark?