Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Issue in upgrading nifi from 2.0.0 M4 to 2.4.0

avatar
Explorer

When we are trying to upgrade apache nifi from 2.0.0 m4 to 2.4.0, We are getting this error 

"/opt/nifi/nifi-current/bin/nifi.sh: 276: exec: 04:10:55,565: not found"
The nifi.sh file is taking some time stamp/junk value in its on of the exec command.
this is snippet from nifi.sh which is causing issue.


if [ "$1" = "run" ]; then
RUN_COMMAND=$(eval "${run_bootstrap_cmd} get-run-command")
RUN_COMMAND_STATUS=$?
if [ $RUN_COMMAND_STATUS = 0 ]; then
exec $RUN_COMMAND
else
echo "Failed to get run command"
echo "${RUN_COMMAND}"
exit 1
fi

We are upgrading nifi in EKS, we can not edit or touch files from official docker image.
Can some one help to fix this issue?

1 REPLY 1

avatar
Visitor

@Chetan_mn Hello, have you found a solution to this please? I have the same problem