Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Unable to delete hbase znode from zookeeper CLI in a kerberized cluster : Authentication is not valid : /hbase-secure/replication

avatar
Explorer

Hi Everyone,

 

I need to delete hbase znode from zokkeeper CLI but getting follwing error when I try that:

[zk: localhost:2181(CONNECTED) 1] rmr /hbase-secure

Authentication is not valid : /hbase-secure/replication

[zk: localhost:2181(CONNECTED) 2]

 

This is the ACL set:

[zk: localhost:2181(CONNECTED) 11] getAcl /hbase-secure

'world,'anyone

: r

'sasl,'hbase

: cdrwa

 

I have even tried to set the ACL as follows but it didn't help either:

[zk: localhost:2181(CONNECTED) 7] setAcl /hbase-secure world:anyone:cdrwa

Authentication is not valid : /hbase-secure

[zk: localhost:2181(CONNECTED) 8] rmr /hbase-secure

Authentication is not valid : /hbase-secure/replication

 

The Cluster is kerberized, what am I missing here? Appreciate all the help!

 

2 REPLIES 2

avatar
New Contributor

When we encounter Authentication is not valid error might be because the user which us trying to delete/modify the ZKnode does not have permissions to do it, please export the JVMFLAG pointing to the jaas file of Hbase {1}

For example in this case I understand we are trying to delete the hbase-secure zknode

So go to the latest hbase process dir, export the hbase jaas file and then log in into ZKCLI again and run the rmr/deleteall command to delete the ZKnode

{1} - export JVMFLAGS=“-Djava.security.auth.login.config=path/to/jaas.conf”

avatar
Community Manager

@Priyanka26 Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. Thanks!


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: