Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-27-2020 03:33 AM
I am setting up a Pre prod cluster from Path B. I ran the command "/usr/share/cmf/schema/scm_prepare_database.sh mysql -h mysqldatabase scm temp password" to check the database status. I am getting the error of log4j however the SCM database is configured correctly. Please find the below error and suggest any workaround for this error.
[root@clouderamanage cloudera-scm-server]# /usr/share/cmf/schema/scm_prepare_database.sh mysql -h webserver scmmysqldatabase password
JAVA_HOME=/usr/java/jdk1.7.0_67-cloudera
Verifying that we can write to /etc/cloudera-scm-server
Creating SCM configuration file in /etc/cloudera-scm-server
Executing: /usr/java/jdk1.7.0_67-cloudera/bin/java -cp /usr/share/java/mysql-connector-java.jar:/usr/share/java/oracle-connector-java.jar:/usr/share/java/postgresql-connector-java.jar:/usr/share/cmf/schema/../lib/* com.cloudera.enterprise.dbutil.DbCommandExecutor /etc/cloudera-scm-server/db.properties com.cloudera.cmf.db.
log4j: ERROR Could not find value for key log4j.appender.A
log4j: ERROR Could not instantiate appender named "A".
[2020-07-27 10:20:19,893] INFO 0[main] - com.cloudera.enterprise.dbutil.DbCommandExecutor.testDbConnection(DbCommandExecutor.java) - Successfully connected to database.
All done, your SCM database is configured correctly!
Created 07-28-2020 12:15 AM
@HanzalaShaikh This seems a very old cosmetic issue in CM. What version you are using?
It appears in older versions we had some early bugs caused by the addition of a new jar file in the classpath directory (/usr/share/cmf/schema/../lib/* ) used by the scm_prepare_db.sh script. This new jar contained a log4j.properties file that was not configured to use the log4j appender A, and overwrote the original properties from the proper log4j.properties file in the original jar file.
Created 07-28-2020 12:15 AM
@HanzalaShaikh This seems a very old cosmetic issue in CM. What version you are using?
It appears in older versions we had some early bugs caused by the addition of a new jar file in the classpath directory (/usr/share/cmf/schema/../lib/* ) used by the scm_prepare_db.sh script. This new jar contained a log4j.properties file that was not configured to use the log4j appender A, and overwrote the original properties from the proper log4j.properties file in the original jar file.
Created 07-30-2020 09:33 AM
Thanks a lot for your quick reply and for providing a detailed explanation, really appreciated. I was using a 5.14.1 version of Cloudera. Yes, there is a bug in the older version I realized soon after that, but your explanation has made me understand the reason behind the error.
Created 03-05-2023 06:01 PM
how to solve this?
Created 03-07-2023 12:04 PM
Welcome to the community @supersonic-2021 . As this is an older post, we recommend starting a new thread. The new thread will provide the opportunity to provide details specific to your environment that could aid others in providing a more accurate answer to your question.