Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-10-2018 09:44 PM - edited 09-16-2022 06:19 AM
Hi everyone
I just upgraded by 3 node research cluster to 5.14.2-1.cdh5.14.2.p0.3. The HDFS, YARN, ZOOKEEPER, HIVE, IMPALA services got successfully installed and upgraded.
I followed the steps in https://www.cloudera.com/documentation/spark2/latest/topics/spark2_installing.html to install 2.3.0.cloudera2-1.cdh5.13.3.p0.316101 install on the cluster
Get the following errors. I am not sure where do I go to see any detail error logs. Nothing is shown in CM
Failed to deploy client configuration to the cluster.
Completed only 4/5 steps. First failure: Failed to execute command Deploy Client Configuration on service Spark 2
Deploy Client Configuration failed.
Generate and deploy client configuration. Completed only 0/3 steps. First failure: Client configuration (id=12) on host hp8300one (id=1) exited with 1 and expected 0. |
Created 07-02-2018 01:22 PM
I resolved this by installing an earlier version of Spark2
1. Deleted Spark2 Service
2. Deactivated, and removed distributed parcel 2.3.0.cloudera2-1.cdh5.13.3.p0.316101
3. Got earlier parcel 2.2.0.cloudera2-1.cdh5.12.0.p0.232957
4. Downloaded and distributed and activated this parcel
5. Got the CSD for this and put into /opt/cloudera/csd
6. Installed Spark2 from CM.
Spark2 up and running on my cluster !
Created 06-10-2018 09:49 PM
sudo grep ERROR /var/log/cloudera-scm-agent/cloudera-scm-agent.log
[10/Jun/2018 21:46:46 +0000] 32685 MainThread util ERROR Lineage file not found, skipping Spark plugin creation: /etc/spark2/conf.cloudera.spark2_on_yarn/navigator.lineage.client.properties
Created 07-02-2018 01:22 PM
I resolved this by installing an earlier version of Spark2
1. Deleted Spark2 Service
2. Deactivated, and removed distributed parcel 2.3.0.cloudera2-1.cdh5.13.3.p0.316101
3. Got earlier parcel 2.2.0.cloudera2-1.cdh5.12.0.p0.232957
4. Downloaded and distributed and activated this parcel
5. Got the CSD for this and put into /opt/cloudera/csd
6. Installed Spark2 from CM.
Spark2 up and running on my cluster !