Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

500 status code received on DELETE method for API: /api/v1/clusters/mycluster

avatar
New Member

In "Cluster install wizard", "Review" step, when I hit "Deploy" button I get the error message

500 status codereceived on DELETE method for API: /api/v1/clusters/mycluster
Error message: Server error

The ambari-server log is

10 Jun 2016 18:31:19,317 ERROR [pool-3-thread-1] AmbariJpaLocalTxnInterceptor:180 - [DETAILED ERROR] Rollback reason: 
Local Exception Stack: 
Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.6.2.v20151217-774c696): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: DELETE command denied to user 'ambari'@'localhost' for table 'alert_notice'
Error Code: 1142
Call: DELETE FROM alert_notice WHERE (history_id IN (?))
        bind => [1 parameter bound]
Query: DeleteAllQuery(name="AlertNoticeEntity.removeByHistoryIds" referenceClass=AlertNoticeEntity sql="DELETE FROM alert_notice WHERE (history_id IN ?)")

And the ambari user privileges on MySQL

+--------------+--------+-------------------------------------------+------------+------------+
| host         | user   | password                                  | Grant_priv | Super_priv |
+--------------+--------+-------------------------------------------+------------+------------+
| localhost    | ambari | *AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA | Y          | Y          |
| 192.168.1.2  | ambari | *AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA | Y          | Y          |
| 127.0.0.1    | ambari | *AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA | Y          | Y          |
+--------------+--------+-------------------------------------------+------------+------------+

Also, ambari user has granted privileges on `ambari.*`.

I running ambari-server (2.2.2.0) on Debian 7.11 (Wheezy), and MySQL server version is 5.5.49. Thanks in advance.

1 ACCEPTED SOLUTION

avatar
Super Guru

seems you dont have delete on alert_notice table can you check it with mysql

in mysql prompt

use information_schema

select * from TABLE_PRIVILEGES;

View solution in original post

4 REPLIES 4

avatar
Super Guru

seems you dont have delete on alert_notice table can you check it with mysql

in mysql prompt

use information_schema

select * from TABLE_PRIVILEGES;

avatar

@Facundo Bianco

Is it a fresh installation of the cluster? It's strange that in a fresh cluster installation, there are entries in alert_notice table.

What is observed when you do a select * from alert_notice ? how many rows are returned? Please backup the database using mysql dump and then try to remove a row from this table to check the privileges [without committing]

avatar
Visitor

@Facundo Bianco Please check disk space on the master node

avatar
New Member
  • I managed to solve the problem

ambari-server restart

,