Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-09-2015 03:58 AM - edited 09-16-2022 02:18 AM
The below error appears after logging in the cloudera manager.
Following a restart of the cloudera manager service the error remains.
Has anyone got any helpful intel?
A server error has occurred. Send the following information to Cloudera.
Path: http://*****************:****/cmf/services/landingPageStatusContent
Version: Cloudera Enterprise 5.0.1 (#257 built by jenkins on 20140512-1726 git: 7919cb55f527d5c6285bc455c93e9f74ebbc37e3)
Created 01-09-2015 07:17 AM
Resolved.
It was a buggy entry in the HOSTS table.
Just execute:
select *
from HOSTS
where ip_address is null or name is null;
Grab the host_id and update the record just in case removing it does any bad juju.
update HOSTS set name = 'ignoreme', ip_address = '0.0.0.0' where host_id = your_host_id_here;
Created 01-09-2015 07:17 AM
Resolved.
It was a buggy entry in the HOSTS table.
Just execute:
select *
from HOSTS
where ip_address is null or name is null;
Grab the host_id and update the record just in case removing it does any bad juju.
update HOSTS set name = 'ignoreme', ip_address = '0.0.0.0' where host_id = your_host_id_here;
Created 04-30-2015 03:26 PM
Hello!
I'm relatively new to the Hadoop ecosystem. Can you tell me from where I would go about querying against the hosts table you mention? Is it a Zookeeper thing? Hive? Any advice or direction towards documentation is greatly appreciated. Thanks!
Created 05-20-2015 02:57 PM
Found it myself, but in case someone else has the same question I did:
On a default CDH install, check /var/lib/cloudera-scm-server-db/data/generated-password.txt for the DB password. Then:
psql -h 127.0.0.1 -p 7432 -U cloudera-scm -W scm
HTH!
Created 03-22-2017 07:36 AM
I am seeing an empty set of hosts
psql (8.4.20)
Type "help" for help.
scm=# select *
scm-# from HOSTS
scm-# where ip_address is null or name is null;
host_id | optimistic_lock_version | host_identifier | name | ip_address | rack_id | status | config_container_id | mainten
ance_count | decommission_count | cluster_id | num_cores | total_phys_mem_bytes | public_name | public_ip_address | cloud_p
rovider
---------+-------------------------+-----------------+------+------------+---------+--------+---------------------+--------
-----------+--------------------+------------+-----------+----------------------+-------------+-------------------+--------
--------
(0 rows)