Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 03-27-2017 03:33 AM - edited 09-16-2022 04:20 AM
I am trying to enable Kerberos for my HDP-2.5 cluster. I have been following through the documentation but on the 'Install and Test Kerberos' the test is failing with the error shown below.
I am using an existing MIT KDC which I have installed on a separate box, and the JCE was unzipped for each host in the cluster.
The KDC connection was ok and I can't seem to find any other people with the same issue. Recently SSL was added to Ambari unsure if this is related. I have tried restarting the Kadmin server but with no avail.
Any help is much appreciated.
Created 03-27-2017 03:51 AM
Also please check if you have installed the following packages on your ambari server?
yum install krb5-server krb5-libs krb5-workstation
Specially the "krb5-workstation" or "krb5-devel" which contains the "kadmin" utility on the ambari-server host.
Created 03-27-2017 03:51 AM
Created 03-27-2017 04:30 AM
Hey there, yes the error is in there hopefully you can make more sense of it.
Created 03-27-2017 03:51 AM
Also please check if you have installed the following packages on your ambari server?
yum install krb5-server krb5-libs krb5-workstation
Specially the "krb5-workstation" or "krb5-devel" which contains the "kadmin" utility on the ambari-server host.
Created on 03-27-2017 04:24 AM - edited 08-18-2019 03:21 AM
Shouldn't the workstations be installed as part of the "Install Kerberos Client" which is being run successfully?
I did do the install on the Ambari host and am now getting a different message would this be because the server is now on the Ambari host.
Created 03-27-2017 04:43 AM
Ok so I updated the /etc/krb5.conf file to the same found on the KDC host and it seems to work now. I didn't see this step anywhere in the documentation and thought the wizard would install the clients.
Thanks a lot!