Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-23-2016 09:31 PM - edited 08-18-2019 03:46 AM
It never happened before but since I played with Kerberos I am getting this message every few mins in Ambari
Created 12-23-2016 09:48 PM
@Sami Ahmad the format for kerberos principal is primary/instance@REALM. For admin principals typically the instance is admin. If the REALM is not specified than the default one will be used. Try passing admin/admin into the "Admin principal" field.
Created 12-23-2016 09:48 PM
@Sami Ahmad the format for kerberos principal is primary/instance@REALM. For admin principals typically the instance is admin. If the REALM is not specified than the default one will be used. Try passing admin/admin into the "Admin principal" field.
Created 12-23-2016 10:05 PM
you misunderstood me , i have no issue logging in, its just that it logs me out after every few mins or if try to start some service inside the ambari console . There is no problem with username or password.
Created 12-24-2016 03:20 AM
ok I reset the KDC credentials via the Manage KDC credentials button and I entered principal as admin/admin.
now I am not getting locked out but if I try to reinstall KMS I am getting t he error below .. he is not finding the krb5.conf file . is there a setting in Kerberos which is messed up ? since as I stated earlier the TGT system is working fine on the command level for HIVE n HBASE ?
... 103 more 23 Dec 2016 22:16:33,131 WARN [ambari-client-thread-837] ServletHandler:561 - Error Processing URI: /api/v1/clusters/FDOT_Hadoop/hosts/hadoop1.abc.com/host_components/RANGER_KMS_SERVER - (java.lang.RuntimeException) Update Host request submission failed: org.apache.ambari.server.AmbariException: The 'krb5-conf' configuration is not available 23 Dec 2016 22:16:33,131 WARN [ambari-client-thread-837] ServletHandler:561 - Error Processing URI: /api/v1/clusters/FDOT_Hadoop/hosts/hadoop1.abc.com/host_components/RANGER_KMS_SERVER - (java.lang.RuntimeException) Update Host request submission failed: org.apache.ambari.server.AmbariException: The 'krb5-conf' configuration is not available
Created on 12-23-2016 10:16 PM - edited 08-18-2019 03:46 AM
Could you please try restarting your ambari server once?
Once restarted, can you run service check for kerberos?
Kerberos service check prompts a window where you need to enter your admin credentials for your kerberos.
Created on 12-24-2016 03:03 AM - edited 08-18-2019 03:45 AM
I don't see any button to do the "service check " how can I run this check ?