Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-23-2018 12:46 AM
hi all
from ambari we got the following alert
how we can identify the reason from this alert ?
Created 10-23-2018 01:04 AM
This is basically a Port check alert
So if you see that message means somehow the zookeeper Host & port was not accessibkle when you noticed that alert.
# telnet master01.sys65.com 2181
.
Please check the access of the host and port from the host where the alert execution got failed.
Also please check the Zookeeper logs of the same time when the alert was triggered to see if there was any error Or if the Zookeeper was down during that time?
.
In ambari UI please check the alert time stamp to know when exactly it was triggered. If the time stamp is bit old then may be you can try Disabling that alert for 10-15 seconds and then enable it back to see if you are noticing any new instance/occurance of that alert.
Created 10-23-2018 01:04 AM
This is basically a Port check alert
So if you see that message means somehow the zookeeper Host & port was not accessibkle when you noticed that alert.
# telnet master01.sys65.com 2181
.
Please check the access of the host and port from the host where the alert execution got failed.
Also please check the Zookeeper logs of the same time when the alert was triggered to see if there was any error Or if the Zookeeper was down during that time?
.
In ambari UI please check the alert time stamp to know when exactly it was triggered. If the time stamp is bit old then may be you can try Disabling that alert for 10-15 seconds and then enable it back to see if you are noticing any new instance/occurance of that alert.
Created 10-23-2018 01:48 AM
hi Jay , I see another problem
as you can see we get connecting and not connected
/usr/hdp/2.6.0.3-8/zookeeper/bin/zkCli.sh
Connecting to localhost:2181 Welcome to ZooKeeper! JLine support is enabled [zk: localhost:2181(CONNECTING) 0]
Created 10-23-2018 01:48 AM
[zk: localhost:2181(CONNECTING) 0] ls /
Exception in thread "main" org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /
at org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
at org.apache.zookeeper.ZooKeeper.getChildren(ZooKeeper.java:1472)
at org.apache.zookeeper.ZooKeeper.getChildren(ZooKeeper.java:1500)
at org.apache.zookeeper.ZooKeeperMain.processZKCmd(ZooKeeperMain.java:723)
at org.apache.zookeeper.ZooKeeperMain.processCmd(ZooKeeperMain.java:591)
at org.apache.zookeeper.ZooKeeperMain.executeLine(ZooKeeperMain.java:363)
at org.apache.zookeeper.ZooKeeperMain.run(ZooKeeperMain.java:323)
at org.apache.zookeeper.ZooKeeperMain.main(ZooKeeperMain.java:282)
You have mail in /var/spool/mail/root
[root@master01 ~]#