Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

All Ambari tasks fail on Sandbox due to configuration parameter hbase-env not found.

avatar
Contributor

Attempting to restart services (such as Oozie or HDFS) or add services (such as Zeppelin) via Ambari using the HDP 2.3.2 Sandbox always fails with some form of the following error ...

raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'hbase-env' was not found in configurations dictionary!
1 ACCEPTED SOLUTION

avatar
Master Mentor

@Brian Weissler

Can you try adding 'ranger-hbase-plugin-enabled' property to : "HBASE" -> "Advanced" -> "Custom ranger-hbase-plugin-properties" section and set the value to yes/no, depending on whether HBase plugin was enabled on Ambari or not. Please restart HBase service after doing the changes.

View solution in original post

2 REPLIES 2

avatar
Master Mentor

@Brian Weissler

Can you try adding 'ranger-hbase-plugin-enabled' property to : "HBASE" -> "Advanced" -> "Custom ranger-hbase-plugin-properties" section and set the value to yes/no, depending on whether HBase plugin was enabled on Ambari or not. Please restart HBase service after doing the changes.

avatar
Contributor

Not sure if it's the expected default or not, but HBase was not installed in my Sandbox. I installed and started it, and suddenly everything is now working in Ambari. I'm able to restart services and was able to install and start Zeppelin.

Thanks.