Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-07-2017 07:20 AM
Hi,
I have setup HDP 2.4.2 cluster using Amabri automated install. I have just one machine. On this I have installed the ambari-agent as well. All was working fine, just high RAM consumption. So, I manually stopped all the services from Ambari UI and then rebooted the machine.
Now when I try to start the ambari server, I get the foll error on the screen:
Waiting for server start.................... ERROR: Exiting with exit code -1. REASON: Ambari Server java process died with exitcode 255. Check /var/log/ambari-server/ambari-server.out for more information.
and inside the ambari-server.log file, I have the following msgs:
07 Mar 2017 12:43:09,823 INFO [main] ViewRegistry:1566 - View deployed: SLIDER{2.0.0}.
07 Mar 2017 12:43:09,828 INFO [main] ViewRegistry:1538 - Reading view archive /var/lib/ambari-server/resources/views/tez-view-2.2.2.0.460.jar.
07 Mar 2017 12:43:10,005 INFO [main] ViewRegistry:1598 - Auto creating instance of view TEZ for cluster winnow.
07 Mar 2017 12:43:10,005 INFO [main] ViewRegistry:1566 - View deployed: TEZ{0.7.0.2.3.4.0-460}.
07 Mar 2017 12:43:10,006 INFO [main] HeartbeatProcessor:154 - **** Starting heartbeats processing threads ****
07 Mar 2017 12:43:10,007 INFO [main] AmbariServer:449 - ********** Started Heartbeat handler **********
07 Mar 2017 12:43:10,008 WARN [ambari-hearbeat-monitor] HeartbeatMonitor:157 - Heartbeat lost from host hdp.com
07 Mar 2017 12:43:10,008 ERROR [main] AmbariServer:844 - Failed to run the Ambari Server
java.lang.NumberFormatException: For input string: "900000000000000"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Integer.parseInt(Integer.java:583)
at java.lang.Integer.parseInt(Integer.java:615)
at org.apache.ambari.server.configuration.Configuration.getConnectionMaxIdleTime(Configuration.java:1570)
at org.apache.ambari.server.controller.AmbariServer.run(AmbariServer.java:502)
at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:842)Not sure what's wrong here!
Thanks
Created 03-07-2017 07:36 AM
Edit the "/etc/ambari-server/conf/ambari.properties" file and lower the value as following. (You seem to have defined too large value there "900000000000000")
server.connection.max.idle.millis=900000
.
The default value can be seen (as '900000') in the Ambari code base as following:
.
That seems to be causing the following error:
ERROR [main] AmbariServer:844 - Failed to run the Ambari Server java.lang.NumberFormatException: For input string: "900000000000000" at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
Created 03-07-2017 07:36 AM
Edit the "/etc/ambari-server/conf/ambari.properties" file and lower the value as following. (You seem to have defined too large value there "900000000000000")
server.connection.max.idle.millis=900000
.
The default value can be seen (as '900000') in the Ambari code base as following:
.
That seems to be causing the following error:
ERROR [main] AmbariServer:844 - Failed to run the Ambari Server java.lang.NumberFormatException: For input string: "900000000000000" at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
Created 03-07-2017 08:00 AM
Thanks a ton @Jay SenSharma. The problem was that I was not able to locate the ambari.properties file. First ambari install. Well, as suggested, I changed the value and now its working.