Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-17-2017 06:03 AM
Hello all - I am reaching out to the community as I have hit a wall. I am attempting to install a Hadoop/Spark cluster on a series of 13 machines - 2 names nodes, 10 data nodes, and 1 hive server. These machines have been provided to me by my infrastructure team, so I have little selection over what I get. They are installed with RHEL 7.3 (Maipo). Memory/CPU/Disk are not an issue at this point, I have 8core/64gb/1tb boxes. This is a small proof of concept.
I have attempted the install with HDP 2.6 and reverted back to try 2.5.3.0 (the last attempt). Each time I get the same issue. It seems Ambari is having issues installing the HDFS client (package: hadoop_2_6_0_3_8). Installing the Ambari server and agents was smooth, no issues there at all. Registering the agents and hosts went fine too. It was only when I attempt to deploy the cluster - that's when the trouble starts. Here is the output from one of the failures:
stderr: /var/lib/ambari-agent/data/errors-147.txtTraceback (most recent call last):
File "/var/lib/ambari-agent/cache/common-services/HDFS/2.1.0.2.0/package/scripts/hdfs_client.py", line 78, in <module>
HdfsClient().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 329, in execute
method(env)
File "/var/lib/ambari-agent/cache/common-services/HDFS/2.1.0.2.0/package/scripts/hdfs_client.py", line 38, in install
self.install_packages(env)
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 708, in install_packages
retry_count=agent_stack_retry_count)
File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 166, in __init__
self.env.run()
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
self.run_action(resource, action)
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
provider_action()
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 54, in action_install
self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 53, in install_package
self.checked_call_with_retries(cmd, sudo=True, logoutput=self.get_logoutput())
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 86, in checked_call_with_retries
return self._call_with_retries(cmd, is_checked=True, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 98, in _call_with_retries
code, out = func(cmd, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 72, in inner
result = function(command, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 102, in checked_call
tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 150, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 303, in _call
raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_0_3_8' returned 1. Error: Nothing to do
stdout: /var/lib/ambari-agent/data/output-147.txt2017-09-15 16:58:19,497 - Stack Feature Version Info: Cluster Stack=2.5, Cluster Current Version=None, Command Stack=None, Command Version=None -> 2.5
2017-09-15 16:58:19,508 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
User Group mapping (user_group) is missing in the hostLevelParams
2017-09-15 16:58:19,509 - Skipping creation of User and Group as host is sys prepped or ignore_groupsusers_create flag is on
2017-09-15 16:58:19,509 - Skipping setting dfs cluster admin and tez view acls as host is sys prepped
2017-09-15 16:58:19,509 - FS Type:
2017-09-15 16:58:19,509 - Directory['/etc/hadoop'] {'mode': 0755}
2017-09-15 16:58:19,511 - Directory['/var/lib/ambari-agent/tmp/hadoop_java_io_tmpdir'] {'owner': 'hdfs', 'group': 'hadoop', 'mode': 01777}
2017-09-15 16:58:19,526 - Initializing 2 repositories
2017-09-15 16:58:19,526 - Repository['HDP-2.5'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.5.3.0', 'action': ['create'], 'components': [u'HDP', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'HDP', 'mirror_list': None}
2017-09-15 16:58:19,536 - File['/etc/yum.repos.d/HDP.repo'] {'content': '[HDP-2.5]\nname=HDP-2.5\nbaseurl=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.5.3.0\n\npath=/\nenabled=1\ngpgcheck=0'}
2017-09-15 16:58:19,537 - Repository['HDP-UTILS-1.1.0.21'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7', 'action': ['create'], 'components': [u'HDP-UTILS', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'HDP-UTILS', 'mirror_list': None}
2017-09-15 16:58:19,541 - File['/etc/yum.repos.d/HDP-UTILS.repo'] {'content': '[HDP-UTILS-1.1.0.21]\nname=HDP-UTILS-1.1.0.21\nbaseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7\n\npath=/\nenabled=1\ngpgcheck=0'}
2017-09-15 16:58:19,541 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2017-09-15 16:58:19,652 - Skipping installation of existing package unzip
2017-09-15 16:58:19,652 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2017-09-15 16:58:19,663 - Skipping installation of existing package curl
2017-09-15 16:58:19,663 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2017-09-15 16:58:19,674 - Skipping installation of existing package hdp-select
2017-09-15 16:58:19,888 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
2017-09-15 16:58:19,901 - Stack Feature Version Info: Cluster Stack=2.5, Cluster Current Version=None, Command Stack=None, Command Version=None -> 2.5
2017-09-15 16:58:19,933 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
2017-09-15 16:58:19,953 - checked_call['rpm -q --queryformat '%{version}-%{release}' hdp-select | sed -e 's/\.el[0-9]//g''] {'stderr': -1}
2017-09-15 16:58:19,985 - checked_call returned (0, '2.6.0.3-8', '')
2017-09-15 16:58:19,996 - Package['hadoop_2_6_0_3_8'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2017-09-15 16:58:20,107 - Installing package hadoop_2_6_0_3_8 ('/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_0_3_8')
2017-09-15 16:58:20,490 - Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_0_3_8' returned 1. Error: Nothing to do
2017-09-15 16:58:20,490 - Failed to install package hadoop_2_6_0_3_8. Executing '/usr/bin/yum clean metadata'
2017-09-15 16:58:20,805 - Retrying to install package hadoop_2_6_0_3_8 after 30 seconds
Command failed after 1 triesI'd be forever in debt to anyone who can help me figure this out. I have been pulling my hair out all week and need to have a running cluster by Monday for a project start date. Does anyone have any ideas on the issue above and how to resolve it? I also found reference to the following post, which seems to be similar to my issue (thought I'm not 100% sure):
I have little control over the OS version, but if anyone has a specific recipe to get Amabari/Hadoop/Spark installed on a working cluster with RHEL 7.3, I am all ears.
Created 09-17-2017 07:32 AM
It should be frustrating, a simple diagnostic isn't easy just a quick look I saw some incompatibility in
2017-09-1516:58:19,901-StackFeatureVersionInfo:ClusterStack=2.5,ClusterCurrentVersion=None,CommandStack=None,CommandVersion=None->2.5
2017-09-1516:58:19,933-Using hadoop conf dir:/usr/hdp/current/hadoop-client/conf
2017-09-1516:58:19,953- checked_call['rpm -q --queryformat '%{version}-%{release}' hdp-select | sed -e 's/\.el[0-9]//g''] {'stderr': -1}
2017-09-1516:58:19,985- checked_call returned (0,'2.6.0.3-8','')There is a conflict between 2.5 and 2.6.0.3-8 can you validate your hdp.repo in /etc/yum.repo.d/*
Make sure you have only the one you intend to install in this case I think 2.6
yum clean all yum repolist
Please revert
Created 09-17-2017 06:03 AM
Also, as an update - I have attempted the process described in:
https://community.hortonworks.com/questions/67376/hdp-25-installation-problem-in-centos7.html
However, I get the same failures to install hadoop/HDFS...
I'm still investigating and trying things, but wanted to update the post that I have tried this solution.
Created 09-17-2017 06:03 AM
Another update- I attempted the suggestion from here:
I installed the libtirpc-devel package using the following method:
yum install libtirpc-devel-0.2.4-0.8.el7_3.i686.rpm
ambari-server reset
Then I started the installation all over again, twice - once with HDP 2.5 and once with 2.6. Neither worked and I get the same error on the installation:
2017-09-15 18:58:41,430 - Package['hadoop_2_6_0_3_8'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2017-09-15 18:58:41,539 - Installing package hadoop_2_6_0_3_8 ('/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_0_3_8')
2017-09-15 18:58:41,922 - Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_0_3_8' returned 1. Error: Nothing to do
2017-09-15 18:58:41,922 - Failed to install package hadoop_2_6_0_3_8. Executing '/usr/bin/yum clean metadata'
2017-09-15 18:58:42,235 - Retrying to install package hadoop_2_6_0_3_8 after 30 secondsStill searching for a solution.....
Created 09-17-2017 06:03 AM
Ok everyone - I think I found the final piece of the solution:
https://community.hortonworks.com/questions/12663/hdp-install-issues-about-hdp-select.html
I had a few nodes that, for some reason, I had to reinstall the hdp-select package on. I'm not sure why and why it wasn't installed by the agent when the deployment started, but for some reason, I had 5 or 6 nodes that, when I ran "yum install hdp-select" it wasn't already installed. After doing that. I re-ran the installation and BAM! Everything started installing as expected. I do believe installing the libtirpc-devel-0.2.4-0.8.el7_3.i686.rpm was a key piece of this too (see my other comment).
In the end:
OS: RHEL 7.2
Ambari 2.5
HDP 2.6
I was able to install HDFS, all the Ambari Metrics stuff, Spark2 and Hive without an issue...
Created 09-17-2017 07:32 AM
It should be frustrating, a simple diagnostic isn't easy just a quick look I saw some incompatibility in
2017-09-1516:58:19,901-StackFeatureVersionInfo:ClusterStack=2.5,ClusterCurrentVersion=None,CommandStack=None,CommandVersion=None->2.5
2017-09-1516:58:19,933-Using hadoop conf dir:/usr/hdp/current/hadoop-client/conf
2017-09-1516:58:19,953- checked_call['rpm -q --queryformat '%{version}-%{release}' hdp-select | sed -e 's/\.el[0-9]//g''] {'stderr': -1}
2017-09-1516:58:19,985- checked_call returned (0,'2.6.0.3-8','')There is a conflict between 2.5 and 2.6.0.3-8 can you validate your hdp.repo in /etc/yum.repo.d/*
Make sure you have only the one you intend to install in this case I think 2.6
yum clean all yum repolist
Please revert