Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-17-2018 10:13 AM
I created an instance because I wanted to use WFM
all setting opt default
but when i using WFM
'Process Check' does not proceed
& i see 'remote API failed'
help me
+++ Kerberos security is disabled
Created 10-17-2018 10:25 AM
Created 10-17-2018 10:25 AM
Are you using Knox by any chance?
Created 10-17-2018 11:07 AM
YES YES using KNOX , RANGER
Created 10-17-2018 11:10 AM
@Jung Heedong
Does accessing the workflow manager view work OK when you're bypassing knox and accessing via ambari directly?
You may be running into a known issue, regarding WFM which results in the 'remote API failed' error if accessed through knox. This is resolved in HDP 3.
Created 10-17-2018 11:13 AM
Could you let me know the commit ID?
Created 10-17-2018 11:14 AM
Does accessing the workflow manager view work OK when you're bypassing knox and accessing via ambari directly? : Possible!
Created 10-17-2018 11:16 AM
I am in a situation where I need to use KNOX in ambari hdp2.0 environment
Created 10-17-2018 12:18 PM
Please refer to this JIRA:
https://issues.apache.org/jira/browse/KNOX-1074
You can try the following workaround, if you are unable to upgrade by making changes in service.xml and rewrite.xml.
You'd find these at
/var/lib/knox/data-<yourHDPversion>/services/ambariui/2.2.0/service.xml /var/lib/knox/data-<yourHDPversion>/services/ambariui/2.2.0/rewrite.xml
Add the following rule in service.xml
<route path="/ambari/api/v1/views/WORKFLOW_MANAGER/versions/**/instances/testwfm/resources/proxy/**"> <rewrite apply="AMBARI/ambari/api/outbound/workflowmanager" to="response.body"/> </route>
And a rule in rewrite.xml
<filter name="AMBARI/ambari/api/outbound/workflowmanager"> <content type="text/plain" asType="text/xml"> </content> </filter>
(restart knox afterwards)
Please take a moment to click accept answer, if this helped you. It will help others find the solution quickly, when looking for the same issue online.
Created 10-17-2018 12:37 PM
Thanks for your help. I cant try now but it was a big help. Can I ask you again if I have a problem?
Created 10-17-2018 12:40 PM
Of course, it may be best to start a new post if you still have any issues, as it will have better visibility. You can tag users (ex. me) in posts by typing '@' followed by their username. That way we get notified when you post 🙂