Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-12-2016 10:32 AM
We are trying to install , HDP via Ambari 2.1, but we during the install process, the ambari server (ambari-server.log) reports that it has lost an heart beat of the agent.
Error Message :
Heartbeat lost from host amabri.agent.com
The ambari-agent log reports:
Failed to connect to https://amabri-server.com:8440/connection_info due to [Errno 111] Connection refused
We are using openjdk 1.7 on RHEL 6.6 64 bit.
Any pointer to the issue would help immensely ?
Created 01-12-2016 05:21 PM
Make sure that your ambari host is correct
make sure that agent is up
iptables is off.
Created 01-12-2016 10:44 AM
what is the output of
curl –u user:passwd http://AmbariHost:8080/api/v1/hosts and curl –u user:passwd http://AmbariHost:8080/api/v1/clusters/YourClusterName/hosts.
Is the hosts listed are same?
Created 01-12-2016 03:12 PM
is the machine with agent still up? Check the uptime. @Anilkumar Panda
Created 01-12-2016 05:21 PM
Make sure that your ambari host is correct
make sure that agent is up
iptables is off.
Created 01-18-2016 09:10 AM
Hi All,
We were able to solve to issue, it was an issue with the host-names and ip addresses not being set correctly .
Thanks for you replies @Neeraj Sabharwal @Artem Ervits @pankaj singh
Created 12-05-2017 12:00 PM
Can you share the answer for this issue??
Created 03-09-2016 02:28 PM
Can you share more details about your solution? Which config / system files you had to change?
Created 06-09-2016 08:48 AM
It was edit to the /etc/hosts files in all the nodes . The hosts file was not set up correctly .