Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-17-2016 05:04 AM
I am trying to access ambari hive llap view and encounter error:
Service 'userhome' check failed: Operation category READ is not supported in state standby
any ideas? I do not get these error for the hive view.
log
Service 'userhome' check failed: org.apache.hadoop.ipc.StandbyException: Operation category READ is not supported in state standby at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:423) at org.apache.hadoop.ipc.RemoteException.instantiateException(RemoteException.java:106) at org.apache.hadoop.ipc.RemoteException.unwrapRemoteException(RemoteException.java:95) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.toIOException(WebHdfsFileSystem.java:509) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.access$800(WebHdfsFileSystem.java:113) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem$AbstractRunner.shouldRetry(WebHdfsFileSystem.java:801) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem$AbstractRunner.runWithRetry(WebHdfsFileSystem.java:767) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem$AbstractRunner.access$100(WebHdfsFileSystem.java:582) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem$AbstractRunner$1.run(WebHdfsFileSystem.java:612) at java.security.AccessController.doPrivileged(Native Method) at javax.security.auth.Subject.doAs(Subject.java:422) at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1724) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem$AbstractRunner.run(WebHdfsFileSystem.java:608) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.getHdfsFileStatus(WebHdfsFileSystem.java:987) at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.getFileStatus(WebHdfsFileSystem.java:1003) at org.apache.ambari.view.utils.hdfs.HdfsApi$3.run(HdfsApi.java:127) at org.apache.ambari.view.utils.hdfs.HdfsApi$3.run(HdfsApi.java:125) at java.security.AccessController.doPrivileged(Native Method) at javax.security.auth.Subject.doAs(Subject.java:422) at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1724) at org.apache.ambari.view.utils.hdfs.HdfsApi.execute(HdfsApi.java:397)
Created 12-19-2016 03:35 PM
@Artem Ervits @Timothy Spann I have confirmed this is a known bug. fixed in next patch.
Created 12-17-2016 04:55 PM
and normal ambari hive it working? weird error, like hadoop is not running.
https://community.hortonworks.com/questions/9790/orgapachehadoopipcstandbyexception.html
Is HDFS in read only mode? Drive issues? Everything else working? Any other logs.
Created 12-17-2016 09:16 PM
Is hdfs in standby? Usually I encounter this when HA is enabled and you're hitting same node. I would check name service ID as both maybe referencing same node. It is easy to fat finger this. alzo make sure proxy user is set http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-views/content/settings_and_cluster...
Created 12-17-2016 09:18 PM
If all else fails use REST API to diagnose https://community.hortonworks.com/articles/72110/ambari-views-rest-api-overview.html
Created 12-19-2016 03:35 PM
@Artem Ervits @Timothy Spann I have confirmed this is a known bug. fixed in next patch.