Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-24-2017 02:25 PM
Log attached : ambari-server.txt
I am trying to install a 3 node cluster using ambari
Machine 1 : Master Node + Local repository + Ambari Server
Machine 2 and 3 : Data Node
Local repository is on the same system as master node and ambari-server.
I am using ambari server 2.4.2 to install hdp 2.5
repolist command lists :
1) HDP-2.5
2) HDP-UTILS-1.1.0.21
3) Updates-ambari-2.4.2.0
I am using passwordless SSH for user hdpuser. This is the logged in user in the system. It is also sudo user. I have confirmed that password SSH works for this user.
After lot of install failures, I am trying to install ONLY master node to understand problem.
I am not get past auto-registration step itself.
I am getting lot of messages like following. Not sure if they are "normal" or cause of problem :
24 May 2017 15:43:14,842 ERROR [alert-event-bus-2] AlertReceivedListener:480 - Unable to process alert ambari_agent_disk_usage for an invalid cluster named HDP
24 May 2017 15:17:17,424 INFO [ambari-client-thread-25] RepoUtil:156 - Found 0 service repos: []
Registration failure logs :
24 May 2017 15:22:33,895 INFO [ambari-client-thread-25] BootStrapImpl:108 - BootStrapping hosts machine1.domain.net: 24 May 2017 15:22:33,901 INFO [Thread-44] BSRunner:190 - Kicking off the scheduler for polling on logs in /var/run/ambari-server/bootstrap/1
24 May 2017 15:22:33,901 INFO [Thread-44] BSRunner:257 - Host= machine1.domain.net bs=/usr/lib/python2.6/site-packages/ambari_server/bootstrap.py requestDir=/var/run/ambari-server/bootstrap/1 user=hdpuser sshPort=22 keyfile=/var/run/ambari-server/bootstrap/1/sshKey passwordFile null server=machine1.domain.net version=2.4.2.0 serverPort=8080 userRunAs=root timeout=300
24 May 2017 15:22:33,903 INFO [pool-16-thread-1] BSHostStatusCollector:55 - Request directory /var/run/ambari-server/bootstrap/1
24 May 2017 15:22:33,903 INFO [pool-16-thread-1] BSHostStatusCollector:62 - HostList for polling on [machine1.domain.net]
24 May 2017 15:22:33,906 INFO [Thread-44] BSRunner:285 - Bootstrap output, log=/var/run/ambari-server/bootstrap/1/bootstrap.err /var/run/ambari-server/bootstrap/1/bootstrap.out at machine1.domain.net
24 May 2017 15:22:43,906 INFO [pool-16-thread-1] BSHostStatusCollector:55 - Request directory /var/run/ambari-server/bootstrap/1
24 May 2017 15:26:53,930 INFO [pool-16-thread-1] BSHostStatusCollector:62 - HostList for polling on [machine1.domain.net]
24 May 2017 15:27:34,092 WARN [Thread-44] BSRunner:292 - Bootstrap process timed out. It will be destroyed.
24 May 2017 15:27:34,093 INFO [Thread-44] BSRunner:309 - Script log Mesg INFO:root:BootStrapping hosts ['machine1.domain.net'] using /usr/lib/python2.6/site-packages/ambari_server cluster primary OS: redhat7 with user 'hdpuser'with ssh Port '22' sshKey File /var/run/ambari-server/bootstrap/1/sshKey password File null using tmp dir /var/run/ambari-server/bootstrap/1 ambari: machine1.domain.net; server_port: 8080; ambari version: 2.4.2.0; user_run_as: root INFO:root:Executing parallel bootstrap Bootstrap process timed out. It was destroyed.
Created 05-26-2017 05:51 AM
Finally solved!! The problem was that even if SSH was setup without password, sudo user ('hdpuser') was setup with password (This means for sudo commands, i was prompted for password).
I modified sudoers entry to make it password less on all cluster machines. That did it!
Created 07-04-2017 05:38 AM
I am also facing same issue. Could please please help on this how to resolve it ?
please help me...
Created 07-18-2018 05:47 PM
Hey can you please share the commands modified in /etc/sudoers. Even i'm facing the same problem since 3 days. please any help me out this.