Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-12-2017 04:54 PM
I am getting this error . I checked the Kerberos principals and keytab is there
[root@hadoop1 ambari-infra-solr]# klist -kte /etc/security/keytabs/ambari-infra-solr.service.keytab Keytab name: FILE:/etc/security/keytabs/ambari-infra-solr.service.keytab KVNO Timestamp Principal ---- ----------------- -------------------------------------------------------- 1 07/12/17 11:53:23 infra-solr/[email protected] (arcfour-hmac) 1 07/12/17 11:53:23 infra-solr/[email protected] (des3-cbc-sha1) 1 07/12/17 11:53:23 infra-solr/[email protected] (aes128-cts-hmac-sha1-96) 1 07/12/17 11:53:23 infra-solr/[email protected] (aes256-cts-hmac-sha1-96) 1 07/12/17 11:53:23 infra-solr/[email protected] (des-cbc-md5)
Connection failed to http://hadoop1.tolls.dot.state.fl.us:8886 (Execution of 'curl --location-trusted -k --negotiate -u : -b /var/lib/ambari-agent/tmp/cookies/f628f5b6-5c65-49c9-8c01-220695d98f74 -c /var/lib/ambari-agent/tmp/cookies/f628f5b6-5c65-49c9-8c01-220695d98f74 -w '%{http_code}' http://hadoop1.tolls.dot.state.fl.us:8886 --connect-timeout 5 --max-time 7 -o /dev/null 1>/tmp/tmpHevOMh 2>/tmp/tmpx3AL8s' returned 7. curl: (7) couldn't connect to host 000)
Created 07-12-2017 05:02 PM
strange ........ I just deleted everything in the log folder and restarted ambari-infra and now its running fine!
Created 07-12-2017 04:59 PM
this is what log is showing
[root@hadoop1 ambari-infra-solr]# more solr-install.log Waiting up to 30 seconds to see Solr running on port 8886/usr/lib/ambari-infra-solr/bin/solr: line 1423: /var/log/ambari-infra-s olr/solr-8886-console.log: Permission denied [-] [/] [root@hadoop1 ambari-infra-solr]# more solr-install.log Waiting up to 30 seconds to see Solr running on port 8886/usr/lib/ambari-infra-solr/bin/solr: line 1423: /var/log/ambari-infra-s olr/solr-8886-console.log: Permission denied [-] [-] Still not seeing Solr listening on 8886 after 30 seconds! tail: cannot open `/var/log/ambari-infra-solr/solr.log' for reading: No such file or directory
Created 07-12-2017 05:02 PM
strange ........ I just deleted everything in the log folder and restarted ambari-infra and now its running fine!