Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Ambari is unable to fetch Host Components

avatar
New Member

Ambari is not able to load service details for all the components like (Hbase,hdfs,zookeeper etc.) after upgrading Ambari from 2.1.2 to 2.4.2. The error found in ambari-server logs is,

22:43:27,505 WARN [ambari-client-thread-2495] ServletHandler:561 - Error Processing URI: /api/v1/clusters/<CLUSTER_NAME>/host_components - (java.lang.ArrayIndexOutOfBoundsException) 1

07 Dec 2016 22:43:27,505 ERROR [ambari-client-thread-2495] ContainerResponse:419 - The RuntimeException could not be mapped to a response, re-throwing to the HTTP container java.lang.ArrayIndexOutOfBoundsException: 1 at org.apache.ambari.server.controller.internal.ResourceManagerHttpPropertyRequest.getConfigPortValue(ResourceManagerHttpPropertyRequest.java:120) at org.apache.ambari.server.controller.internal.ResourceManagerHttpPropertyRequest.getPort(ResourceManagerHttpPropertyRequest.java:93) at org.apache.ambari.server.controller.internal.ResourceManagerHttpPropertyRequest.getUrl(ResourceManagerHttpPropertyRequest.java:77) at org.apache.ambari.server.controller.internal.HttpPropertyProvider.populateResource(HttpPropertyProvider.java:133) at org.apache.ambari.server.controller.internal.HttpPropertyProvider.populateResources(HttpPropertyProvider.java:117) at org.apache.ambari.server.controller.internal.ClusterControllerImpl.populateResources(ClusterControllerImpl.java:155) at org.apache.ambari.server.api.query.QueryImpl.queryForResources(QueryImpl.java:424) at org.apache.ambari.server.api.query.QueryImpl.execute(QueryImpl.java:222) at org.apache.ambari.server.api.handlers.ReadHandler.handleRequest(ReadHandler.java:77) at org.apache.ambari.server.api.services.BaseRequest.process(BaseRequest.java:145) at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:126) at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:90) at org.apache.ambari.server.api.services.HostComponentService.getHostComponents(HostComponentService.java:104) at sun.reflect.GeneratedMethodAccessor253.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(JavaMethodInvokerFactory.java:60) 07 Dec 2016

1 ACCEPTED SOLUTION

avatar
Not applicable

@Prabhat Singh

Can you pelase check if the following properties are set correctly? yarn.resourcemanager.webapp.https.address.XYZ with port 8090 (default)

Example:

yarn.resourcemanager.webapp.https.address = erie3.example.com:8090
yarn.resourcemanager.webapp.https.address.rm1 = erie3.example.com:8090
yarn.resourcemanager.webapp.https.address.rm2 = erie2.example.com:8090

Similarly please check the

yarn.resourcemanager.webapp.address

- Please make sure that the Port is mentioned in the address. Missing port can cause this issue.

.

View solution in original post

3 REPLIES 3

avatar
Not applicable

@Prabhat Singh

Can you pelase check if the following properties are set correctly? yarn.resourcemanager.webapp.https.address.XYZ with port 8090 (default)

Example:

yarn.resourcemanager.webapp.https.address = erie3.example.com:8090
yarn.resourcemanager.webapp.https.address.rm1 = erie3.example.com:8090
yarn.resourcemanager.webapp.https.address.rm2 = erie2.example.com:8090

Similarly please check the

yarn.resourcemanager.webapp.address

- Please make sure that the Port is mentioned in the address. Missing port can cause this issue.

.

avatar
New Member

Hi jss,

Thanks for a quick response. This is what i can see,

yarn.resourcemanager.webapp.https.address=<hostname>:8090
yarn.resourcemanager.hostname.rm1=<hostname>
yarn.resourcemanager.webapp.address.rm1=<hostname>
yarn.resourcemanager.hostname.rm2=<hostname>
yarn.resourcemanager.webapp.address=<hostname>:8088

We have two more cluster where we are running version 2.4.1.0 of Ambari. The two are working fine with above properties. Is there any major change in Ambari 2.4.2?

Please suggest.

avatar
New Member

By adding the port solves the issue.

Thanks a lot @jss