Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-12-2016 05:23 AM
<title>Error 403 GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos credentails)</title>
</head> <body><h2>HTTP ERROR 403</h2> <p>Problem accessing /webhdfs/v1/ats/done. Reason: <pre> GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos credentails)</pre></p><hr /><i><small>Powered by Jetty://</small></i><br/> <br/>
Created 10-14-2016 03:56 PM
Thanks Santhosh B Gowda I solved it by deleting old disabling and enabling kerberos, generating new key tabs for the whole components and manually creating key tabs for Yarn App timeline server
Created 10-12-2016 12:54 PM
Can you please try kinit using the hiveserver2 keytab and see whether this is successful. keytab will be found on the machine with hiveserver2 at below location
/etc/security/keytabs/hive.service.keytab
To find the principle name, try below command which returns the principal name
[hive@XYX ~]$ klist -kt /etc/security/keytabs/hive.service.keytab Keytab name: FILE:/etc/security/keytabs/hive.service.keytab KVNO Timestamp Principal ---- ----------------- -------------------------------------------------------- 4 09/06/16 04:04:06 hive/[email protected]
Now kinit using the principle name as below and let us know whether it successful.
kinit -kt /etc/security/keytabs/hive.service.keytab hive/[email protected]
Created 10-12-2016 03:48 PM
Hi Santhosh, Here is the result of the list & kinit commands, it seems successful. but still can't start hive2server
[root@10-0-0-81 ~]# klist -kt /etc/security/keytabs/hive.service.keytab
Keytab name: FILE:/etc/security/keytabs/hive.service.keytab
KVNO Timestamp Principal
---- ----------------- --------------------------------------------------------
3 10/12/16 01:55:33 hive/[email protected]
3 10/12/16 01:55:33 hive/[email protected]
3 10/12/16 01:55:33 hive/[email protected]
3 10/12/16 01:55:33 hive/[email protected]
3 10/12/16 01:55:33 hive/[email protected]
Created 10-14-2016 05:04 AM
Can you please provide the complete logs for hiveserver2 start-up issue. hiveserver2 logs are available at /var/log/hive/hiveserver2.log
Created 10-14-2016 03:56 PM
Thanks Santhosh B Gowda I solved it by deleting old disabling and enabling kerberos, generating new key tabs for the whole components and manually creating key tabs for Yarn App timeline server