Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-07-2018 04:04 AM
I have freshly imported Sandbox 2.6.4. When I try to start Atlas It gives me following error:
No live SolrServers available to handle this request
I have realized that Solr service was in Ambari Infra component. So I started Ambari Infra then tried again Atlas but got following error:
resource_management.core.exceptions.ExecutionFailed: Execution of 'cat /var/lib/ambari-agent/tmp/atlas_hbase_setup.rb | hbase shell -n' returned 1. atlas_titan ATLAS_ENTITY_AUDIT_EVENTS atlas TABLE java exception ERROR Java::JavaIo::IOException: Can't get master address from ZooKeeper; znode data == null
I tried again after starting HBase but the error turned into the following:
resource_management.core.exceptions.ExecutionFailed: Execution of 'cat /var/lib/ambari-agent/tmp/atlas_hbase_setup.rb | hbase shell -n' returned 1. atlas_titan ATLAS_ENTITY_AUDIT_EVENTS atlas TABLE java exception ERROR Java::OrgApacheHadoopHbaseIpc::RemoteWithExtrasException: org.apache.hadoop.hbase.PleaseHoldException: Master is initializing at org.apache.hadoop.hbase.master.HMaster.checkInitialized(HMaster.java:2732) at org.apache.hadoop.hbase.master.MasterRpcServices.getTableNames(MasterRpcServices.java:943) at org.apache.hadoop.hbase.protobuf.generated.MasterProtos$MasterService$2.callBlockingMethod(MasterProtos.java:59924) at org.apache.hadoop.hbase.ipc.RpcServer.call(RpcServer.java:2150) at org.apache.hadoop.hbase.ipc.CallRunner.run(CallRunner.java:112) at org.apache.hadoop.hbase.ipc.RpcExecutor$Handler.run(RpcExecutor.java:187) at org.apache.hadoop.hbase.ipc.RpcExecutor$Handler.run(RpcExecutor.java:167)
How can start Atlas?
Created 07-07-2018 02:47 PM
Did you restart atlas after starting hbase and solr?
Created 07-07-2018 02:47 PM
Did you restart atlas after starting hbase and solr?
Created 07-09-2018 05:31 PM
Two days later. I have just tried to restart Atlas while HBase and Solr is already running. It has started. Thanks @sunile.manjee
Created 07-19-2018 01:49 PM
A week later I got similar problem again. When I closed some other services Atlas could be able to start. I think unsufficient resourses prevent Atlas to start.