Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Atlas hive import script (import_hive.sh) is failing

avatar
Expert Contributor

This is a kerberized cluster on HDP 2.6.1

import_hive.sh is failing with the errors as below

2017-09-21 10:38:53,105 ERROR - [pool-2-thread-10 - f15b1a2e-6904-49bb-8ed5-b832632d4339:atlas:POST/api/atlas/entities/bedf80dd-deb1-42a9-81cc-40336a3d4546] ~ Unable to update entity by GUID bedf80dd-deb1-42a9-81cc-40336a3d4546 {  "jsonClass":"org.apache.atlas.typesystem.json.InstanceSerialization$_Reference",  "id":{    "jsonClass":"org.apache.atlas.typesystem.json.InstanceSerialization$_Id",    "id":"bedf80dd-deb1-42a9-81cc-40336a3d4546",    "version":0,    "typeName":"hive_db",    "state":"ACTIVE"  },  "typeName":"hive_db",  "values":{    "name":"default",    "location":"hdfs://CLUSTERNAME/apps/hive/warehouse",
Using Hive configuration directory [/etc/hive/conf]Log file for import is /usr/hdp/current/atlas-server/logs/import-hive.logException in thread "main" org.apache.atlas.hook.AtlasHookException: HiveMetaStoreBridge.main() failed.        at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.main(HiveMetaStoreBridge.java:650)Caused by: org.apache.atlas.AtlasServiceException: Metadata service API org.apache.atlas.AtlasBaseClient$APIInfo@69c6161d failed with status 500 (Internal Server Error) Response Body ({"error":"Failed to notify for change PARTIAL_UPDATE"})        at org.apache.atlas.AtlasBaseClient.callAPIWithResource(AtlasBaseClient.java:337)        at org.apache.atlas.AtlasBaseClient.callAPIWithResource(AtlasBaseClient.java:287)        at org.apache.atlas.AtlasBaseClient.callAPI(AtlasBaseClient.java:429)        at org.apache.atlas.AtlasClient.callAPIWithBodyAndParams(AtlasClient.java:1006)        at org.apache.atlas.AtlasClient.updateEntity(AtlasClient.java:583)       at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.updateInstance(HiveMetaStoreBridge.java:526)        at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.registerDatabase(HiveMetaStoreBridge.java:175)        at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.importDatabases(HiveMetaStoreBridge.java:140)        at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.importHiveMetadata(HiveMetaStoreBridge.java:134)        at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.main(HiveMetaStoreBridge.java:647)Failed to import Hive Data Model!!!
1 ACCEPTED SOLUTION

avatar
Expert Contributor

Deleting the kafka topics for atlas and restart of atlas fixed the issue.

View solution in original post

2 REPLIES 2

avatar
Expert Contributor

@Yogeshprabhu Can you share the logs from atlas server too (application.log) ? Looks like Atlas is not able to post to ATLAS_ENTITIES topic (outgoing notification).

avatar
Expert Contributor

Deleting the kafka topics for atlas and restart of atlas fixed the issue.