Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-11-2015 07:48 AM - edited 09-16-2022 02:28 AM
Hi all,
I'm trying to backup fsimage on a secure cluster with the -fetchImage command.
I want to execute it without using hdfs user, but with an administrative user(adminUser) which belongs to hdfs' supergroup (dfs.permissions.supergroup, dfs.permissions.superusergroup = supergroup)
adminUser is local to the machine.
When I try the command:
kinit adminUser
hdfs dfsadmin -fetchImage /backup_folder
I obtain the following error:
15/05/11 16:38:42 WARN security.UserGroupInformation: PriviledgedActionException as:adminUser@<DOMAIN.LOCAL> (auth:KERBEROS) cause:org.apache.hadoop.hdfs.server.namenode.TransferFsImage$HttpGetFailedException: Image transfer servlet at http://<namenode>:50070/imagetransfer?getimage=1&txid=latest failed with status code 403
Response message:
Only Namenode, Secondary Namenode, and administrators may access this servlet
fetchImage: Image transfer servlet at http://<namenode>:50070/imagetransfer?getimage=1&txid=latest failed with status code 403
Response message:
Only Namenode, Secondary Namenode, and administrators may access this servlet
However, others dfsadmin commands (like -report) work fine with adminUser.
Thanks in advance
Created 05-12-2015 11:19 PM
Created 05-12-2015 11:19 PM
Created 05-14-2015 04:21 AM
It works!
Thanks!