Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
12-30-2014
01:05 PM
- last edited on
04-21-2026
06:59 AM
by
GrazittiAPI
Hey,
I've just set up an env of CDH 5.3 [from CM 5.3] and wanted to check some things with Hive. So i tried to use Hue to do it and I got this error:
Error while compiling statement: FAILED: RuntimeException Cannot create staging directory 'hdfs://h1.t.pl:8020/jobs/input/customer/.hive-staging_hive_2014-12-30_21-48-01_539_4882491936626833078-1': Permission denied: user=admin, access=WRITE, inode="/jobs/input/customer":hdfs:supergroup:drwxrwxr-x
at org.apache.hadoop.hdfs.server.namenode.DefaultAuthorizationProvider.checkFsPermission(DefaultAuthorizationProvider.java:257)
admin is an user i'm logged into hue webui - default user created with install of cloudera manager.
Is it configuration issue?
[edit]
tables were created from external files using query run through hue:
create external table customer ( C_CUSTKEY int, C_NAME string, C_ADDRESS string, C_NATIONKEY int, C_PHONE string, C_ACCTBAL decimal(10,2), C_MKTSEGMENT string, C_COMMENT string ) row format delimited fields terminated by '|' stored as textfile location '/jobs/input/customer';
Created on 01-07-2015 01:13 AM - edited 01-07-2015 01:24 AM
Well, so my problem was kind'a linux related I guess., with file permissions I had 2 logical partitions which were mounted at / and /home. By default I had dir /dfs on / partition and when i was low with storage space i decided to create a new directory for dfs under /home. Of course I've made chown to hdfs user for this folder (as is for /dfs) but it gave me error from the first post.
After I resized partition size and left only one dir /dfs as a storage point for hdfs on node everything worked out fine.
Created 12-30-2014 01:25 PM
Created on 01-07-2015 01:13 AM - edited 01-07-2015 01:24 AM
Well, so my problem was kind'a linux related I guess., with file permissions I had 2 logical partitions which were mounted at / and /home. By default I had dir /dfs on / partition and when i was low with storage space i decided to create a new directory for dfs under /home. Of course I've made chown to hdfs user for this folder (as is for /dfs) but it gave me error from the first post.
After I resized partition size and left only one dir /dfs as a storage point for hdfs on node everything worked out fine.
Created 01-07-2015 07:53 AM
Created 01-07-2015 11:24 AM
Yeah, I always try to do that because I personally hate when I find a similar problem to mine and only a reply from the author that he managed to resolve that already but doesn't explain how xP
regards,
ive