Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 03-11-2018 12:52 AM - edited 09-16-2022 05:57 AM
Hi,
I have tried cloud 5.14 insstallation with path A. tried with single node/multinode.i ran the installtion from root user.
it always failed in " cluster steup steps"
When i went threought the log file found the below issues and tried to fix it manaully .
1> The cloudera-scm user got created, but doesnt have sudo privillage guiven by root user. i gave it manually'
2> neither zookrrper/name node/hdfs starets , because , it was unable to create any of the directories under /var/lib or var/log or /dfs.
3> Also the auto installer didnt create the os user like zookeeepr/hdfs users. . thats why it is faling.
i have selinux disabled
[root@centosgold snn]# sestatus
SELinux status: disabled
[root@centosgold snn]#
Please help
some of the error
Invalid config, exiting abnormally
org.apache.zookeeper.server.quorum.QuorumPeerConfig$ConfigException: Error processing /run/cloudera-scm-agent/process/26-zookeeper-server/zoo.cfg
at org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.java:131)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:106)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:79)
Caused by: java.lang.IllegalArgumentException: dataLogDir /var/lib/zookeeper is missing.
at org.apache.zookeeper.server.quorum.QuorumPeerConfig.parseProperties(QuorumPeerConfig.java:287)
at org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.java:127)
... 2 more
=================
2:02:54.536 PM ERROR Main
Error creating LevelDB timeseries store in directory /var/lib/cloudera-service-monitor/ts
java.io.IOException: Unable to create new directory at /var/lib/cloudera-service-monitor/ts/ts_entity_metadata
at com.cloudera.cmon.tstore.leveldb.LDBUtils.openVersionedDB(LDBUtils.java:257)
at com.cloudera.cmon.tstore.leveldb.LDBUtils.openVersionedDB(LDBUtils.java:212)
at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.openMetadataDB(LDBTimeSeriesMetadataStore.java:148)
at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.<init>(LDBTimeSeriesMetadataStore.java:138)
at com.cloudera.cmon.firehose.Main.main(Main.java:474)
=-================
Unable to access datadir, exiting abnormally
org.apache.zookeeper.server.persistence.FileTxnSnapLog$DatadirException: Missing data directory /var/lib/zookeeper/version-2, automatic data directory creation is disabled (zookeeper.datadir.autocreate is false). Please create this directory manually.
at org.apache.zookeeper.server.persistence.FileTxnSnapLog.<init>(FileTxnSnapLog.java:102)
at org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:109)
at org.apache.zookeeper.server.ZooKeeperServerMain.initializeAndRun(ZooKeeperServerMain.java:91)
at org.apache.zookeeper.server.ZooKeeperServerMain.main(ZooKeeperServerMain.java:53)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:121)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:79)
======================
Created 03-12-2018 11:46 AM
Hi Datta,
You should not have to give anyone privs, CM will take care of that all for you.
Tina
Created 03-12-2018 11:28 AM
Hi Tina,
one more thing , do we have to give all users cloudera-scm,apache,hdfs ,zookeper sudo preivilalges before installation . or it ewill automaically taken care
Datta
Created 03-12-2018 11:46 AM
Hi Datta,
You should not have to give anyone privs, CM will take care of that all for you.
Tina
Created 03-13-2018 10:45 AM
Hi Tina,
my CDH is up and running now , when i unechked single user option , thanks .
Datta