Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-26-2017 04:22 AM - edited 09-16-2022 05:17 AM
Hi,
I have a partitionned tables that have more than 50k partitions, it work a good except the Hive Metastore operations, like DROP and ALTER ... RENAME, I face this error message:
Query: drop table cars ERROR: ImpalaRuntimeException: Error making 'dropTable' RPC to Hive Metastore: CAUSED BY: MetaException: Timeout when executing method: drop_table_with_environment_context; 600003ms exceeds 600000ms
I don't now if it's, a memory problem, or it's normal and I should adjust the timeout value.. ? if yes, which one ?
Thanks to help me ASAP.
Created 10-02-2017 04:01 PM
Created 10-04-2017 03:38 AM
Created 05-07-2019 10:28 PM
Hi Vibin,
I can see that this issue is tracked under HIVE-6980 on the upstream JIRA. And I can confirm that it has been fixed in CDH6.1 and CDH5.16 onwards.
If you are using older version, you can try to increase the value for hive.metastore.client.socket.timeout as a workaround as mentioned in the previous post.
Hope above is helpful.
Cheers
Eric
Created 10-02-2017 04:01 AM
Created 10-02-2017 08:50 AM
Can you try dropping the table using Hive?
Created on 10-02-2017 09:26 AM - edited 10-02-2017 09:42 AM
Thank you very muth for the answer man
I tried to drop it with the hive, but it give this error message:
hive> drop table cars; FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. MetaException(message:hive.metastore.sasl.enabled can't be false in non-testing mode)
I think it's another problem that we have to fix, did you have any idea ?
NB: I use Sentry with hive.
Created 10-02-2017 04:01 PM
Created 10-03-2017 03:58 AM
Hi @EricL,
Thanks for the replay,
Can you give me the JIRA track link of this issue please ?
And about 'hive.metastore.client.socket.timeout' I find 3 config variables with the same name:
1- Hive: Hive Metastore Connection Timeout (5m).
2- Hive: in : Service Monitor Client Config Overrides (value: 60).
3- Impala: Catalog Server Hive Metastore Connection Timeout and Impala Daemon Hive Metastore Connection Timeout (value: 1h).
Can you help me to know which one is the concerned ?
Hope this issue iresolved ASAP.
Thanks again.
Created 10-04-2017 03:38 AM
Created 10-06-2017 10:13 AM
Yes man, that what I do now in *drop* statement, but so far no easy solution for *alter*.
Thanks again @EricL
Created 10-08-2017 03:14 AM
Created 05-06-2019 11:10 PM
@EricL Just wanted to know if there is any progress on this issue ? I too face the same issue - wanted to drop a table with 50k partitions.