Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-26-2017 04:22 AM - edited 09-16-2022 05:17 AM
Hi,
I have a partitionned tables that have more than 50k partitions, it work a good except the Hive Metastore operations, like DROP and ALTER ... RENAME, I face this error message:
Query: drop table cars ERROR: ImpalaRuntimeException: Error making 'dropTable' RPC to Hive Metastore: CAUSED BY: MetaException: Timeout when executing method: drop_table_with_environment_context; 600003ms exceeds 600000ms
I don't now if it's, a memory problem, or it's normal and I should adjust the timeout value.. ? if yes, which one ?
Thanks to help me ASAP.
Created 10-02-2017 04:01 PM
Created 10-04-2017 03:38 AM
Created 05-07-2019 10:28 PM
Hi Vibin,
I can see that this issue is tracked under HIVE-6980 on the upstream JIRA. And I can confirm that it has been fixed in CDH6.1 and CDH5.16 onwards.
If you are using older version, you can try to increase the value for hive.metastore.client.socket.timeout as a workaround as mentioned in the previous post.
Hope above is helpful.
Cheers
Eric
Created 05-07-2019 10:28 PM
Hi Vibin,
I can see that this issue is tracked under HIVE-6980 on the upstream JIRA. And I can confirm that it has been fixed in CDH6.1 and CDH5.16 onwards.
If you are using older version, you can try to increase the value for hive.metastore.client.socket.timeout as a workaround as mentioned in the previous post.
Hope above is helpful.
Cheers
Eric
Created 05-07-2019 11:14 PM
Created 05-08-2019 12:43 AM