Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-19-2016 08:44 AM
Created 07-19-2016 11:58 AM
Hello,
From the logs, I found that it was stuck updating the hdfs location.
So, I updated the hdfs location manually by running the command metatool -updateLocation
After that I was able to bring up the Hiveserver2 service.
Best Regards,
Rinku Singh.
Created 07-19-2016 09:08 AM
Just tweak the timeout number and see if error persist...
sed -e 's/\(agent.task.timeout=\).*/\12700/' \
-e 's/\(agent.package.install.task.timeout=\).*/\12700/' \
-i /etc/ambari-server/conf/ambari.properties
Created 07-19-2016 09:51 AM
Hello @Mukesh Kumar
I don't think increasing the timeout number will help here. There must be something that is stopping it from start.
From the ambari-ui, I could see the below error:
Connection failed on host ip-172-31-31-251.us-west-2.compute.internal:10000 (Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/alerts/alert_hive_thrift_port.py", line 200, in execute
check_command_timeout=int(check_command_timeout))
File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/hive_check.py", line 74, in check_thrift_port_sasl
timeout=check_command_timeout)
File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__
self.env.run()
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
self.run_action(resource, action)
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
provider_action()
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run
tries=self.resource.tries, try_sleep=self.resource.try_sleep)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
result = function(command, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
tries=tries, try_sleep=try_sleep)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
raise Fail(err_msg)
Fail: Execution of '! beeline -u 'jdbc:hive2://ip-172-31-31-251.us-west-2.compute.internal:10000/;transportMode=binary' -e '' 2>&1| awk '{print}'|grep -i -e 'Connection refused' -e 'Invalid URL'' returned 1. Error: Could not open client transport with JDBC Uri: jdbc:hive2://ip-172-31-31-251.us-west-2.compute.internal:10000/;transportMode=binary: java.net.ConnectException: Connection refused (state=08S01,code=0)
Error: Could not open client transport with JDBC Uri: jdbc:hive2://ip-172-31-31-251.us-west-2.compute.internal:10000/;transportMode=binary: java.net.ConnectException: Connection refused (state=08S01,code=0)
)
Created 07-19-2016 10:06 AM
Check with Hive start service command below:-
Created 07-19-2016 11:58 AM
Hello,
From the logs, I found that it was stuck updating the hdfs location.
So, I updated the hdfs location manually by running the command metatool -updateLocation
After that I was able to bring up the Hiveserver2 service.
Best Regards,
Rinku Singh.