Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-26-2017 06:07 PM
Hey,
i am currently evaluating using cloudbreak to deploy a HDP cluster. However when i try do deploy a cluster with cloudbreak the following error occurs:
Infrastructure creation failed. Reason: Failed to create the stack for CloudContext{id=3, name='marius1', platform='StringType{value='OPENSTACK'}', owner='4a7f9d4b-e68d-4a4b-ae00-5dcd9cf64b8c'} due to: Resource CREATE failed: BadRequest: resources.router_gateway: Invalid input for external_gateway_info. Reason: 'None' is not a valid UUID. Neutron server returns request_ids: ['req-69341fcc-ec4b-4576-b694-cbd0cf44a007']
Were are using Openstack Newton which is not officially supported, however i would like to know if this is version problem or a config problem. We do not have a free floating ip pool (only one per project allowed) so created a network using a subnet 192.168.0.0/24 and with no floating ip pool. This results into the shown error.
Cheers
Marius
Created on 05-04-2017 01:11 PM - edited 08-17-2019 08:40 PM
Hi,
It does not seem to related to the version of OpenStack.
It looks like that OS::Neutron::Router creation failed. Resource creation defined here: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op... .
Floating IP pool is not created by Cloudbreak we just use that id what you specify during network creation: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op...
May I ask you to try to deploy into an existing subnet. So create a network and a subnet manually and specify the network/subnet and floating pool ids when you create a network. Please see attached screenshot.
Thanks,
Attila
Created on 05-04-2017 01:11 PM - edited 08-17-2019 08:40 PM
Hi,
It does not seem to related to the version of OpenStack.
It looks like that OS::Neutron::Router creation failed. Resource creation defined here: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op... .
Floating IP pool is not created by Cloudbreak we just use that id what you specify during network creation: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op...
May I ask you to try to deploy into an existing subnet. So create a network and a subnet manually and specify the network/subnet and floating pool ids when you create a network. Please see attached screenshot.
Thanks,
Attila
Created 05-09-2017 01:04 PM
Did that and it worked. Thanks a lot.
Created 05-09-2017 07:13 PM
hi @Marius Dieckmann, if you think that the answer was useful, then you might consider to accept it :). Thanks.