Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-16-2016 03:54 AM
Hi,
I've updated to cloudbreak 1.2.2 and am trying to install a 2.4.2 HDP Cluster on AWS and failing with this error:
Ambari cluster could not be created. Reason: com.sequenceiq.cloudbreak.service.cluster.AmbariOperationFailedException: Cannot use the specified Ambari stack: AmbariStackDetails{id=34, stack='HDP', version='2.4.2', os='redhat7', stackRepoId='HDP-2.4', utilsRepoId='HDP-UTILS-1.1.0.20', stackBaseURL='http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0', utilsBaseURL='http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos7', verify=true}. Error: org.apache.ambari.server.controller.spi.NoSuchResourceException: The specified resource doesn't exist: Stack data, Stack HDP 2.4.2 is not found in Ambari metainfo
Does anyone see where my definition is wrong?
Created 05-18-2016 05:29 PM
You can give it a try now on the hosted version or do these changes in your cbd Profile:
export DOCKER_TAG_CLOUDBREAK=1.2.6-rc.3
And then restart cbd with:
cbd kill && cbd regenerate && cbd start
Created 05-16-2016 03:54 AM
@Kenneth Graves the repo http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos7 does not exist. nor does http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0
Please take a look here for the correct HDP repos.
Created 05-16-2016 04:01 AM
Hi @Sunile Manjee So these repos are not correct?
Created 05-17-2016 12:54 AM
@Kenneth Graves I just tried and I am recieving issues as well. I believe this is a bug. @jeff do you have any info?
Created 05-17-2016 07:55 AM
Can you please share the repo urls that you have tried.
I'm from the RE team, validated all the repos and they are all good. No issues on our side.
Created 05-18-2016 05:24 PM
Folks found from @Janos Matyas this is a block bug.
Created 05-18-2016 05:29 PM
You can give it a try now on the hosted version or do these changes in your cbd Profile:
export DOCKER_TAG_CLOUDBREAK=1.2.6-rc.3
And then restart cbd with:
cbd kill && cbd regenerate && cbd start
Created 05-23-2016 03:36 AM
I face this something similar issue in my environment.
com.sequenceiq.cloudbreak.service.cluster.AmbariOperationFailedException: Cannot use the specified Ambari stack: AmbariStackDetails{id=2, stack='HDP', version='2.3', os='redhat7', stackRepoId='HDP', utilsRepoId='HDP-UTILS-1.1.0.20', stackBaseURL='http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.3.0.0', utilsBaseURL='http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos7', verify=false}. Error: org.apache.ambari.server.controller.spi.NoSuchResourceException: The specified resource doesn't exist: Stack data, stackName=HDP, stackVersion= 2.3, osType=redhat7, repoId= HDP
Can anyone assist?
Thanks.