Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Cloudbreak fails to scale down node containing knox_gateway component

avatar
New Member

I used Cloudbreak to scale up one of our node groups, which contained the know_gateway component.

When I tried to scale it back down, the action failed because knox_gateway was running on these nodes.

Why is it possible to upscale these nodes, but not downscale them?

Is there a way around this issue?

1 ACCEPTED SOLUTION

avatar
New Member

I think my problem was trying to scale the wrong node group. I was under the impression that the client group was the one used as spark slaves - but found out it was the slaves group doing the heavy lifting.

Thanks for the help.

View solution in original post

2 REPLIES 2

avatar
Super Collaborator

I think you should see some error in ambari UI could you check that please ?

Also could you please provide some cloudbreak log?

Br,

Richard

avatar
New Member

I think my problem was trying to scale the wrong node group. I was under the impression that the client group was the one used as spark slaves - but found out it was the slaves group doing the heavy lifting.

Thanks for the help.