Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-21-2017 01:04 PM
Hi,
I'm trying to upscale the cluster from Cloudbreak and getting the below error:
update failed: New node(s) could not be added to the cluster. Reason com.sequenceiq.cloudbreak.service.CloudbreakServiceException: Ambari could not install services. Invalid Add Hosts Template: org.apache.ambari.server.topology.InvalidTopologyTemplateException: Must specify either host_name or host_count for hostgroup: worker
Error log from Ambari-server:
ERROR [ambari-client-thread-3771] BaseManagementHandler:67 - Bad request received: Invalid Add Hosts Template: org.apache.ambari.server.topology.InvalidTopologyTemplateException: Must specify either host_name or host_count for hostgroup: worker
I also could see the same error details from Ambari server log after enabling DEBUG Log mode.
Cloudbreak Version: 1.16.5
Ambari server version:- 2.6.0.0
Any help on the issue is appreciated!
Thanks,
Cibi
Created 12-21-2017 06:15 PM
Please use Ambari 2.5.1 as Ambari 2.6 is not working with Cloudbreak yet. This bug is resolved in Ambari 2.6.1
Created 12-21-2017 01:56 PM
Verify your HDP/Ambari version to see if you are running into this issue. https://issues.apache.org/jira/browse/AMBARI-22005
Created 12-21-2017 06:15 PM
Please use Ambari 2.5.1 as Ambari 2.6 is not working with Cloudbreak yet. This bug is resolved in Ambari 2.6.1
Created 12-26-2017 01:57 PM
Hi @mmolnar,
In the JIRA for this issue, AMBARI-22005 i could see that the issue has been resolved in Ambari 2.6.0. Anyways i have posted a comment over there to confirm the same.
Thanks,
Cibi
Created 12-26-2017 08:47 PM
The jira issue regarding this bug is AMBARI-22539 which is fixed in 2.6.1
Created 12-27-2017 08:02 AM
Thanks for the details @mmolnar. Appreciate your help on this.