Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-06-2016 08:12 AM - edited 09-16-2022 03:17 AM
Hi,
after upgrading Cloudera Manager from 5.5 to 5.7 our custom role failed to start due to the following error:
Role failed to start due to error java.lang.IllegalStateException: The archive already contains log4j.properties.
here is a log message in the cloudera-scm-server log:
2016-05-06 10:41:42,024 INFO CommandPusher:com.cloudera.cmf.service.GenericBring
UpRoleCommand: BringUp command (2866) has finished on service test for role
55/test-MASTER-1d1313da90923719ced954c04b73e153, with status FAI
LURE and message MessageWithArgs{messageId=message.command.role.bringUp.failedTo
Start, args=[java.lang.IllegalStateException: The archive already contains log4j
.properties]}
2016-05-06 10:41
I have a second role that starts correctly. The above role uses the following logging instruction:
"logging" : {
"dir" : "/var/log/test",
"filename" : "all.log",
"modifiable" : true,
"configName" : "log.dir",
"loggingType" : "log4j"
},thanks,
Created on 05-09-2016 03:59 AM - edited 05-09-2016 03:16 PM
Thanks for confirming, seems like you're hitting the same issue.
Workaround options;
- do not use SPARK_ON_YARN dependecy and make sure your role is pointing to an existing up-to-date /etc/spark/conf dir
- in the service.sdl rename default log4j.properties as set by configFilename [1] to a different name (ie: real-log4j.properties). Then, in the control.sh script, move the log4j.properties file to the spark-conf dir where it belongs, and move the real-log4j.properties to be renamed as log4j.properties.
[1] https://github.com/cloudera/cm_ext/wiki/Service-Descriptor-Language-Reference#logging
Created 05-06-2016 08:47 AM
would you be able to list your 'serviceDependencies', there's a know issue that we've identified with SPARK/CSD - just wanted to confirm if you're running into the same.
Created 05-06-2016 12:01 PM
How do I list the serviceDependencies ? Regardless, our CSD depends on Spark.
Created 05-09-2016 01:04 AM
Hi Michalis,
here are our dependencies:
"parcel" : {
"requiredTags" : ["test", "cdh"],
"optionalTags" : ["test-plugin"]
},
"serviceDependencies" : [
{ "name" : "YARN", "required" : "true" },
{ "name" : "SPARK_ON_YARN", "required" : "true" },
{ "name" : "ZOOKEEPER"}
],
"dependencyExtensions" : [
{
"extensionId" : "yarnAuxService",
"name": "monitor",
"className" : "com.test.monitoring.YarnMonitoringService",
"type" : "classAndConfigs"
}
Created on 05-09-2016 03:59 AM - edited 05-09-2016 03:16 PM
Thanks for confirming, seems like you're hitting the same issue.
Workaround options;
- do not use SPARK_ON_YARN dependecy and make sure your role is pointing to an existing up-to-date /etc/spark/conf dir
- in the service.sdl rename default log4j.properties as set by configFilename [1] to a different name (ie: real-log4j.properties). Then, in the control.sh script, move the log4j.properties file to the spark-conf dir where it belongs, and move the real-log4j.properties to be renamed as log4j.properties.
[1] https://github.com/cloudera/cm_ext/wiki/Service-Descriptor-Language-Reference#logging
Created 06-01-2016 07:36 PM
Hi :
I also encountered same issue, also I have to declared spark_on_yarn dependency, how to fix it or workaround it?could you give the solution example,thanks!