Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-09-2016 06:42 PM
Even I have right permission my data node not starting up. Gives following error :(Connection failed: [Errno 111] Connection refused to 0.0.0.0:50010)
[root@ip pig]# cd /hadoop/hdfs/data
[root@ip hdfs]# ls -lrt
total 0
drwxr-x---. 3 hdfs hadoop 20 Apr 5 10:54 data
drwxr-xr-x. 4 hdfs hadoop 63 Apr 9 14:08 namenode
drwxr-xr-x. 3 hdfs hadoop 38 Apr 9 14:16 namesecondary
Just want to add .. last time when the everything was running i did floowing..
added the mapred user to HDFS group and given him rwx permission on / directory... can this be a reason of failure?
Just to add Not only datanode everything else is not running now.. is there any way to know what may have gone wrong?
Created 04-12-2016 04:45 AM
Thank you all... I have got it resolved. I did 2 things..
1. for name node : I simply changed the port to some other value
2. For data-node : I found an error message in logs saying that "/" has permission 777 , cannot start data-node. I remember I had changed it manually for some other problem. Reverting it resolved the issue.
Created 04-09-2016 06:43 PM
Can you check if iptables and selinux is stop.
Created 04-09-2016 07:07 PM
how to do that can you please help me.
Created 04-09-2016 11:00 PM
Hi, Can anyone help me please?
Created 04-10-2016 03:06 AM
Created 04-10-2016 11:42 PM
Commands doesn't seems to give answer.
Created 04-10-2016 04:38 AM
Follow this personal documents substitute the names accordingly
Created 04-10-2016 06:07 PM
Have you tried the above solutions ?
Created 04-10-2016 11:42 PM
It is not working... looks like all of my commands are failing.. non of them are able to perform task here is the attached output of commnds I ran. errors.txt
Created 04-11-2016 12:16 AM
Looks like I have disabled both of the things firewall and selinux ...still no luck.
[root@ip-xxxxxxxx ec2-user]# systemctl status firewalld.service
● firewalld.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)
[root@ip-xx-xx-xx-xx ec2-user]# sestatus SELinux status: disabled
is there any logs or something which can help?