Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-26-2016 01:14 PM
My setup is a 3 node VM cluster as mentioned in Quick Start guide.
When i run Start all services it fails at datanode start with error
/usr/hdp/2.4.2.0-258//hadoop-hdfs/bin/hdfs.distro: line 317: /home/vagrant/jdk1.8.0_60_x64/bin/java: Permission denied /usr/hdp/2.4.2.0-258//hadoop-hdfs/bin/hdfs.distro: line 317: exec: /home/vagrant/jdk1.8.0_60_x64/bin/java: cannot execute: Permission denied ulimit -a for user hdfs core file size (blocks, -c) unlimited data seg size (kbytes, -d) unlimited scheduling priority (-e) 0 file size (blocks, -f) unlimited pending signals (-i) 22958 max locked memory (kbytes, -l) 64 max memory size (kbytes, -m) unlimited open files (-n) 128000 pipe size (512 bytes, -p) 8 POSIX message queues (bytes, -q) 819200 real-time priority (-r) 0 stack size (kbytes, -s) 10240 cpu time (seconds, -t) unlimited max user processes (-u) 65536 virtual memory (kbytes, -v) unlimited file locks (-x) unlimited ~
Created 07-26-2016 04:06 PM
Error says:
/home/vagrant/jdk1.8.0_60_x64/bin/java: Permission denied
So can you please check if your Java has 755 (or execute permission) for the user ?
try setting
chmod 755 -R /home/vagrant/jdk1.8.0_60_x64/bin
Created 07-26-2016 04:06 PM
Error says:
/home/vagrant/jdk1.8.0_60_x64/bin/java: Permission denied
So can you please check if your Java has 755 (or execute permission) for the user ?
try setting
chmod 755 -R /home/vagrant/jdk1.8.0_60_x64/bin
Created 09-16-2016 08:38 AM
This didn't work for me so i finally destroyed the setup and recreated a fresh setup. And it worked. Thanks @jk for the pointers.