Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Deploy Client Config retries infinitely after failure

avatar
Contributor

I have a custom CSD with a gateway service role that runs a control script command at deploy client config.

 

when the control script fails (script returns non-zero), the UI reports failure but the command seems to be retried infinitely (did a ps auxf on any host that has the gateway role). 

Furthermore, i cannot investigate the logs in the ccdeploy directory since the directory is constantly wiped. 

 

Are these retries intended or can i signal no retry with a specific exit code?

 

thanks

1 ACCEPTED SOLUTION

avatar
Hi,

CM will continually re-try client config deployment. This is helpful in particular if the host is temporarily not available and comes online later. It makes it easier for the administrator to reason about the state of client configs, so you don't have to worry about re-executing the command on a few random hosts that weren't operational at the time of deploy. So the retries are intended.

Ideally, the deploy scripts should be so simple that they can't really fail. If you're just debugging your changes, then you can stop the CM agent (service cloudera-scm-agent stop) on that host to stop the wiping / retry logic and make it easier to debug.

Thanks,
Darren

View solution in original post

1 REPLY 1

avatar
Hi,

CM will continually re-try client config deployment. This is helpful in particular if the host is temporarily not available and comes online later. It makes it easier for the administrator to reason about the state of client configs, so you don't have to worry about re-executing the command on a few random hosts that weren't operational at the time of deploy. So the retries are intended.

Ideally, the deploy scripts should be so simple that they can't really fail. If you're just debugging your changes, then you can stop the CM agent (service cloudera-scm-agent stop) on that host to stop the wiping / retry logic and make it easier to debug.

Thanks,
Darren