Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-29-2017 10:25 AM
Hi,
I've created the demo topology from the SAM docs. When deploying, it fails instantly with the following message:
An exception with message [/tmp/b7ea53f1-77ca-495f-b9f7-ed28f3097ac1.jar (No such file or directory)] was thrown while processing request.
Created 03-29-2017 06:02 PM
@Ward Bekker can you copy bootstrap/notifier-jars/streamline-notifier*.jar onto /tmp/b7ea53f1-77ca-495f-b9f7-ed28f3097ac1.jar and try re-deploying
Created 03-29-2017 05:57 PM
@Ward Bekker are you using notifications or custom processor in your topology
Created 03-29-2017 06:02 PM
I'm using the email alert processor as per demo instructions.
Created 03-29-2017 06:02 PM
@Ward Bekker can you copy bootstrap/notifier-jars/streamline-notifier*.jar onto /tmp/b7ea53f1-77ca-495f-b9f7-ed28f3097ac1.jar and try re-deploying
Created 03-29-2017 06:03 PM
Yes will do
Created 03-29-2017 07:10 PM
Yay, one step further, I now get the error below, which makes sense because storm-client is misspelled. Any pointers?
An exception with message [Cannot run program "/usr/hdf/current/storm-clint/bin/storm": error=2, No such file or directory] was thrown while processing request.
Created 03-29-2017 07:14 PM
found it, was misspeld in the config yml.
Created 03-29-2017 07:20 PM
Ok, I was able to deploy the topology. Thx!