Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

ERROR [main] master.HMasterCommandLine: Master exiting java.lang.RuntimeException: Failed construction of Master: class org.apache.hadoop.hbase.master.HMaster

avatar
Rising Star

Recently we had moved ambari-server to other host. cluster is kerberized.

metrics collector service dies after sometime with below error in ambari-metrics-collector.log

ERROR [main] master.HMasterCommandLine: Master exiting java.lang.RuntimeException: Failed construction of Master: class org.apache.hadoop.hbase.master.HMaster

1 ACCEPTED SOLUTION

avatar
Rising Star

this is resolved.

after checking /var/log/ambari-metrics-collector/hbase-ams-master-XXXX.log

found

Caused by: javax.security.auth.login.LoginException: Unable to obtain password from user.

checked keytabs files under /etc/security/keytabs/ams-hbase.master.keytab

after klist to this keytab came to know that its has invalid entry for hosts.

klist -ekt ams-hbase.master.keytab

Keytab name: FILE:ams-hbase.master.keytab

KVNO Timestamp Principal ---- ----------------- -------------------------------------------------------- 2 07/04/16 03:09:57 host/[email protected] (aes256-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (aes128-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (des3-cbc-sha1) 2 07/04/16 03:09:57 host/[email protected] (arcfour-hmac) 2 07/04/16 03:09:57 host/[email protected] (aes256-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (aes128-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (des3-cbc-sha1) 2 07/04/16 03:09:57 host/[email protected] (arcfour-hmac) 2 07/13/16 11:11:54 [email protected] (aes256-cts-hmac-sha1-96) 2 07/13/16 11:11:54 [email protected] (aes128-cts-hmac-sha1-96) 2 07/13/16 11:11:54 [email protected] (des3-cbc-sha1) 2 07/13/16 11:11:54 [email protected] (arcfour-hmac) 3 07/13/16 11:14:14 [email protected] (aes256-cts-hmac-sha1-96) 3 07/13/16 11:14:14 [email protected] (aes128-cts-hmac-sha1-96) 3 07/13/16 11:14:14 [email protected] (des3-cbc-sha1) 3 07/13/16 11:14:14 [email protected] (arcfour-hmac) 4 07/13/16 11:15:46 [email protected] (aes256-cts-hmac-sha1-96) 4 07/13/16 11:15:46 [email protected] (aes128-cts-hmac-sha1-96) 4 07/13/16 11:15:46 [email protected] (des3-cbc-sha1) 4 07/13/16 11:15:46 [email protected] (arcfour-hmac) 2 09/21/16 11:11:23 amshbase/[email protected] (aes256-cts-hmac-sha1-96) 2 09/21/16 11:11:23 amshbase/[email protected] (aes128-cts-hmac-sha1-96) 2 09/21/16 11:11:23 amshbase/[email protected] (des3-cbc-sha1) 2 09/21/16 11:11:23 amshbase/[email protected] (arcfour-hmac) 3 09/21/16 11:13:40 amshbase/[email protected] (aes256-cts-hmac-sha1-96) 3 09/21/16 11:13:40 amshbase/[email protected] (aes128-cts-hmac-sha1-96) 3 09/21/16 11:13:40 amshbase/[email protected] (des3-cbc-sha1) 3 09/21/16 11:13:40 amshbase/[email protected] (arcfour-hmac) 4 09/21/16 11:15:07 amshbase/[email protected] (aes256-cts-hmac-sha1-96) 4 09/21/16 11:15:07 amshbase/[email protected] (aes128-cts-hmac-sha1-96) 4 09/21/16 11:15:07 amshbase/[email protected] (des3-cbc-sha1) 4 09/21/16 11:15:07 amshbase/[email protected] (arcfour-hmac)

so deleted that keytab file and generated new keytab with valid entries and placed on the metrics-collector host under /etc/security/keytabs

restarted metrics-collector service the service started.

View solution in original post

1 REPLY 1

avatar
Rising Star

this is resolved.

after checking /var/log/ambari-metrics-collector/hbase-ams-master-XXXX.log

found

Caused by: javax.security.auth.login.LoginException: Unable to obtain password from user.

checked keytabs files under /etc/security/keytabs/ams-hbase.master.keytab

after klist to this keytab came to know that its has invalid entry for hosts.

klist -ekt ams-hbase.master.keytab

Keytab name: FILE:ams-hbase.master.keytab

KVNO Timestamp Principal ---- ----------------- -------------------------------------------------------- 2 07/04/16 03:09:57 host/[email protected] (aes256-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (aes128-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (des3-cbc-sha1) 2 07/04/16 03:09:57 host/[email protected] (arcfour-hmac) 2 07/04/16 03:09:57 host/[email protected] (aes256-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (aes128-cts-hmac-sha1-96) 2 07/04/16 03:09:57 host/[email protected] (des3-cbc-sha1) 2 07/04/16 03:09:57 host/[email protected] (arcfour-hmac) 2 07/13/16 11:11:54 [email protected] (aes256-cts-hmac-sha1-96) 2 07/13/16 11:11:54 [email protected] (aes128-cts-hmac-sha1-96) 2 07/13/16 11:11:54 [email protected] (des3-cbc-sha1) 2 07/13/16 11:11:54 [email protected] (arcfour-hmac) 3 07/13/16 11:14:14 [email protected] (aes256-cts-hmac-sha1-96) 3 07/13/16 11:14:14 [email protected] (aes128-cts-hmac-sha1-96) 3 07/13/16 11:14:14 [email protected] (des3-cbc-sha1) 3 07/13/16 11:14:14 [email protected] (arcfour-hmac) 4 07/13/16 11:15:46 [email protected] (aes256-cts-hmac-sha1-96) 4 07/13/16 11:15:46 [email protected] (aes128-cts-hmac-sha1-96) 4 07/13/16 11:15:46 [email protected] (des3-cbc-sha1) 4 07/13/16 11:15:46 [email protected] (arcfour-hmac) 2 09/21/16 11:11:23 amshbase/[email protected] (aes256-cts-hmac-sha1-96) 2 09/21/16 11:11:23 amshbase/[email protected] (aes128-cts-hmac-sha1-96) 2 09/21/16 11:11:23 amshbase/[email protected] (des3-cbc-sha1) 2 09/21/16 11:11:23 amshbase/[email protected] (arcfour-hmac) 3 09/21/16 11:13:40 amshbase/[email protected] (aes256-cts-hmac-sha1-96) 3 09/21/16 11:13:40 amshbase/[email protected] (aes128-cts-hmac-sha1-96) 3 09/21/16 11:13:40 amshbase/[email protected] (des3-cbc-sha1) 3 09/21/16 11:13:40 amshbase/[email protected] (arcfour-hmac) 4 09/21/16 11:15:07 amshbase/[email protected] (aes256-cts-hmac-sha1-96) 4 09/21/16 11:15:07 amshbase/[email protected] (aes128-cts-hmac-sha1-96) 4 09/21/16 11:15:07 amshbase/[email protected] (des3-cbc-sha1) 4 09/21/16 11:15:07 amshbase/[email protected] (arcfour-hmac)

so deleted that keytab file and generated new keytab with valid entries and placed on the metrics-collector host under /etc/security/keytabs

restarted metrics-collector service the service started.