Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-09-2016 06:12 AM
Dear Experts
All the datanodes nodes in cluster found below an error and could not contacted to cluster after installed cdh 5.9.0 on ubuntu.
"Error, CM server guid updated, expected 85587073-270d-43d9-a44a-e213d9f7e45b, received 4c1402a5-8364-4598-a382-0c760710e897"
Created 11-10-2016 05:15 PM
Got the same issue on my newly installed 5.9 version cluster.
Fixed it by deleting /var/lib/cloudera-scm-agent/cm_guid on each node.
Check here: https://www.cloudera.com/documentation/enterprise/release-notes/topics/cm_rn_known_issues.html
Created 11-10-2016 12:01 PM
I am also facing the same issue, can anyone has solution for this.
Apprecited your kind help in advance.
Created 11-10-2016 05:15 PM
Got the same issue on my newly installed 5.9 version cluster.
Fixed it by deleting /var/lib/cloudera-scm-agent/cm_guid on each node.
Check here: https://www.cloudera.com/documentation/enterprise/release-notes/topics/cm_rn_known_issues.html
Created 04-11-2018 09:12 PM
any resolution ?
Created 09-12-2019 09:17 AM
Yes,
rm cm_guid
rm: remove regular file ‘cm_guid’? yes
and run service cloudera-scm-agent restart.
Should do the trick up to cloudera 6.1
Created 03-06-2020 07:52 AM
Thanks a million.
Got same issue after re-adding a host that was removed prior to upgrade from CDH 5.6 to CDH 6.2
Fixed it by deleting /var/lib/cloudera-scm-agent/cm_guid on the node
Created 03-02-2021 10:08 PM
I had a similar issue in CDH 6.21 and doing this worked .
rm -rf /var/lib/cloudera-scm-agent/cm_guid