Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-12-2013 10:01 AM - edited 09-16-2022 01:47 AM
sometimes, error message on thrift server console:
FAILED: Error in semantic analysis: Lock manager could not be initialized, check hive.lock.manager Check hive.zookeeper.quorum and hive.zookeeper.client.port
background:
1. sqlserver's linked server ----odbc---->hive thrift server.
2. just run select * from sqlserver on hive tables/views, no error; when build cube by sqlserver, then this error.
any suggestions?
Created 09-20-2013 08:42 AM
Hi,
Are you using Hive Server 1 or Hive Server 2? We strongly recommend Hive Server 2. If you are using HS2 it sounds like the Table Lock Manager is not correctly configured. The steps to do so are located on this page:
Created 09-20-2013 08:42 AM
Hi,
Are you using Hive Server 1 or Hive Server 2? We strongly recommend Hive Server 2. If you are using HS2 it sounds like the Table Lock Manager is not correctly configured. The steps to do so are located on this page:
Created 09-24-2013 01:33 AM
I am using hive server 1.
OK, I will try hive server 2.
Thanks.