Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 11-03-2016 02:51 AM - edited 09-16-2022 03:46 AM
->Cloudera manager installation-done for 2 servers
->HA done
->CDH installation for one manager-done
->CDH installation for 32 servers-error
/tmp/scm_prepare_node.Ephf7nOy
using SSH_CLIENT to get the SCM hostname: 10.*.*.44 37998 22
opening logging file descriptor
Starting installation script...
Acquiring installation lock...
BEGIN flock 4
END (0)
Detecting root privileges...
effective UID is 0
Detecting distribution...
BEGIN grep Tikanga /etc/redhat-release
END (1)
BEGIN grep 'CentOS release 5' /etc/redhat-release
END (1)
BEGIN grep 'Scientific Linux release 5' /etc/redhat-release
END (1)
BEGIN grep Santiago /etc/redhat-release
END (1)
BEGIN grep 'CentOS Linux release 6' /etc/redhat-release
END (1)
BEGIN grep 'CentOS release 6' /etc/redhat-release
END (1)
BEGIN grep 'Scientific Linux release 6' /etc/redhat-release
END (1)
BEGIN grep Maipo /etc/redhat-release
END (1)
BEGIN grep 'CentOS Linux release 7' /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)
END (0)
/etc/redhat-release ==> CentOS 7
Detecting Cloudera Manager Server...
BEGIN host -t PTR 10.*.*.44
Host 44.*.*.10.in-addr.arpa. not found: 3(NXDOMAIN)
END (1)
BEGIN which python
/usr/bin/python
END (0)
BEGIN python -c 'import socket; import sys; s = socket.socket(socket.AF_INET); s.settimeout(5.0); s.connect((sys.argv[1], int(sys.argv[2]))); s.close();' 10.*.*.44 7182
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/usr/lib64/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
socket.error: [Errno 113] No route to host
END (1)
could not contact scm server at 10.*.*.44:7182, giving up
waiting for rollback request
Created 11-21-2016 08:50 AM
Created 11-21-2016 08:50 AM
Created 01-05-2018 08:26 AM
I am getting the same kind of error. and not able to get the config.ini file i the /etc/cloudera-scm-server folder.
Created 01-08-2018 05:53 AM
Created on 01-08-2018 05:54 AM - edited 01-08-2018 05:55 AM
if you want to change any thing in the cloudera manager config
checkout the below path
/etc/default/cloudera-scm-server
Created 01-08-2018 08:01 AM
Hi @csguna -
Below is what i could see in the
/etc/default/cloudera-scm-server
Not sure where to make the server host change. Kindly let me know your inputs.
#
# Specify any command line arguments for the Cloudera SCM Server here.
#
CMF_SERVER_ARGS=""
#
# Locate the JDBC driver jar file.
#
# The default value is the default system mysql driver on RHEL/CentOS/Ubuntu
# and the standard, documented location for where to put the oracle jar in CM
# deployments.
#
export CMF_JDBC_DRIVER_JAR="/usr/share/java/mysql-connector-java.jar:/usr/share/java/oracle-connector-java.jar"
#
# Java Options.
#
# Default value sets Java maximum heap size to 2GB, and Java maximum permanent
# generation size to 256MB.
#
export CMF_JAVA_OPTS="-Xmx2G -XX:MaxPermSize=256m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp"
Created on 01-08-2018 07:14 PM - edited 01-08-2018 07:15 PM
Could you check the below path , thats were you can change the server_host -
/etc/cloudera-scm-agent/config.ini
, if you did not find one that means you havent installed cloudera scm agent
Created 01-08-2018 09:30 PM
Hi All,
Thank you for your resolution. I was able to resolve the issue. The issue was with /etc/hosts file and the firewall service was also running, so stopped that as well.