Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-16-2017 06:20 AM
I started Pig with pig -x local and loaded the hdfs file ina relation. When I executed DUMP command, it threw the below error:
ERROR 1066: Unable to open iterator for alias events. Backend error : java.lang.IllegalStateException: Job in state DEFINE instead of RUNNING org.apache.pig.impl.logicalLayer.FrontendException: ERROR 1066: Unable to open iterator for alias events. Backend error : java.lang.IllegalStateException: Job in state DEFINE instead of RUNNING
Created 08-16-2017 03:49 PM
Can you paste the whole log? Hard to tell from this excerpt. There might be an earlier error causing this. As well, why are you running this in local mode? Did you try restarting the grunt shell ? I also hit some weird errors which cleared after restarting the shell which was in an inconsistent state.
Created 08-16-2017 03:49 PM
Can you paste the whole log? Hard to tell from this excerpt. There might be an earlier error causing this. As well, why are you running this in local mode? Did you try restarting the grunt shell ? I also hit some weird errors which cleared after restarting the shell which was in an inconsistent state.
Created 08-17-2017 06:23 AM
Thankyou for your response. I figured my AWS services were not starting properly and hence it was giving this error. Solved my issue. Also Thanks, I needed to run Pig instead of pig -x local.
Created 08-18-2017 12:58 PM
Thanks for the update. Glad it helped. Can you please accept the answer ?