Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Exception while invoking getNewApplication of class ApplicationClientProtocolPBClientImpl over rm2 after 1 fail over attempts. Trying to fail over after sleeping for 27400ms.

avatar
Expert Contributor

Trying to run map reduce using below cmd and it's failing. Any insights about this error?

yarn jar /usr/hdp/current/hadoop-mapreduce-client/hadoop-mapreduce-examples.jar teragen -Dmapreduce.job.queuename=default 100000000 ${P}/test-${i}

16/05/30 11:41:32 INFO impl.TimelineClientImpl: Timeline service address: https://***.:8190/ws/v1/timeline/ 16/05/30 11:41:33 INFO client.ConfiguredRMFailoverProxyProvider: Failing over to rm2 16/05/30 11:41:33 INFO retry.RetryInvocationHandler: Exception while invoking getNewApplication of class ApplicationClientProtocolPBClientImpl over rm2 after 1 fail over attempts. Trying to fail over after sleeping for 27400ms.

java.net.ConnectException: Call From **.*.***.* to 10.**.**.***:8032 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Thank you Ravi.

HA Zookeeper Connection State: Auto Failover is not enabled, after enabling this it worked.

View solution in original post

2 REPLIES 2

avatar
Guru

It looks like you have issues with your Resource Manager1 and your app is trying to switch over to Rresource Manager2. You can take a look at RM1 logs to see what the error is. It is either down or not responding on 8032 on time.

avatar
Expert Contributor

Thank you Ravi.

HA Zookeeper Connection State: Auto Failover is not enabled, after enabling this it worked.