Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-11-2015 01:37 AM
running "pig 1.pig" from the tutorial http://hortonworks.com/hadoop-tutorial/faster-pig-... yields the error
Input(s): Failed to read data from "/user/guest/Batting.csv"
Output(s): Counters: Total records written : 0 Total bytes written : 0 Spillable Memory Manager spill count : 0 Total bags proactively spilled: 0 Total records proactively spilled: 0
Job DAG: null->null, null
Created 12-11-2015 07:42 PM
@Matthew bird You need a home directory for the user in HDFS so here is what is needed -
#Login as root to the sandbox su - hdfs hdfs dfs -mkdir /user/root hdfs dfs -chown root:hadoop /user/root hdfs dfs -chmod 755 /user/root
Try to run the pig script after you've done the above steps.
Created 12-11-2015 07:53 PM
definitely progress. Now it is looping: http://pastebin.com/bqgSDYdb I am not sure if this is still about permissions or not.
Created 12-11-2015 09:17 PM
Check if the services are up, looks like your Job History Server may be down.
Created 12-12-2015 03:58 AM
I got it working with a fresh instance of HDP_2.3.2_virtualbox.
I set root:hadoop as owner of /user/root and did the same for /user/guest and that did the trick. Thanks everyone.
Created 12-11-2015 11:21 PM
I see 'Connection Refused' which means either a service is down or connection to wrong port. Like Deepesh said, appears to be former and that History server is down.
Created 11-16-2017 06:46 PM
I am still facing this issue. Matthew Bird - can you help me? How did you get fresh instance?